[Freedombox-discuss] Cannot ssh into the box any more

Michael info at fonfon.at
Mon May 16 08:46:19 UTC 2016

I think everybody should deactivate automatic upgrades immediately!

On 2016-05-16 09:03, Dietmar wrote:
> As the title says, ssh into the FBx gives error "Permission denied,
> please try again." Tried several times.

I did a fresh install of a cubietruck followed by a dist-upgrade and had
the same problem: SSH login doesn't work anymore, Plinth login is still

I added my public SSH key via Plinth, so I'm able to login via SSH
again. But on "sudo su -" I get this error:

sudo: PAM authentication error: Module is unknown

One of the modules of your unattended-upgrades was 'libpam-abl'...

Dietmar, perhaps your edit-user page still works so you can add an SSH key?

And I can't login on my (development) VirtualMachine anymore either.

On 2016-05-16 09:03, Dietmar wrote:
> As the title says, ssh into the FBx gives error "Permission denied,
> please try again." Tried several times.
> Directly before this message, I did not do anything particular, I just
> went frequently into the box to read conf and log files of repro.
> Things I have been working on were:
> - changing the host name from "freedombox" to "Myfreedombox" to make
> sure it does not forget the domain names. I just changed it back, no change.
> - Playing with Monkeysphere. I went up to publishing the key (SSH and
> HTTPS) but interrupted the validation process on my computer.
> - Tried to get SIP working. But I did this mostly on the laptop and the
> android phone, some conf settings in repro
> So nothing I would attribute directly to the issue with permission denied.
> Apps (ikiwiki, calendar) are still working, so is Plinth. Due to the
> error 500 (mentioned some days ago) I cannot manage the users in Plinth.
> Last log of unattended upgrades is
>> 2016-05-15 08:46:27,408 INFO Initial blacklisted packages: 
>> 2016-05-15 08:46:27,421 INFO Initial whitelisted packages: 
>> 2016-05-15 08:46:27,422 INFO Starting unattended upgrades script
>> 2016-05-15 08:46:27,423 INFO Allowed origins are: ['origin=Debian', 'origin=Debian,codename=sid,label=Debian-Security']
>> 2016-05-15 13:14:34,492 INFO Packages that will be upgraded: gcc-6-base libatomic1 libcc1-0 libgcc1 libgomp1 libjansson4 libpam-abl libstdc++6 libubsan0 php-symfony-class-loader php-symfony-console php-symfony-event-dispatcher php-symfony-process php-symfony-routing php7.0-cli php7.0-common php7.0-curl php7.0-json php7.0-mbstring php7.0-opcache php7.0-readline php7.0-sqlite3 php7.0-xml
>> 2016-05-15 13:14:34,495 INFO Writing dpkg log to '/var/log/unattended-upgrades/unattended-upgrades-dpkg.log'
>> 2016-05-15 13:18:01,822 INFO All upgrades installed
> Does anyone else have this issue (which could indicate it has to do with
> this upgrade). If it is only me, is there any way to get back in? Had
> lots of moments of panic yesterday. I did not yet make a backup of my
> ikiwiki :- (
> Alternatively, I would buy a new µSD card, set up the box again and try
> to copy the unsaved data to it. It's going to rain the next evenings
> anyway...
> _______________________________________________
> Freedombox-discuss mailing list
> Freedombox-discuss at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss

More information about the Freedombox-discuss mailing list