[Freedombox-discuss] 403 error when connecting from the outside.

A. F. Cano afc at shibaya.lonestar.org
Sun Nov 6 03:58:53 UTC 2016


I have tried to connect to the freedombox from the outside and I get a
403 Error: "you do not have permission..."

The Dynamic DNS Client is set up (gnudip.datasystems24.net) to a domain
under freedombox.rocks (HUGE thanks to whoever set this up!) and I do
get to the freedombox.  The message is generated by plinth (it says at
the bottom of the error page)  but I get the 403 message.  Then I
obtained a certificate (through the "Certificates (Let's Encrypt)" page
thinking that this might be the problem, but I still get the same error.

Certifate status			Website Security

Expires on Jan 28 18:27:00 2017 GMT	Enabled

If I "Run Diagnostics" from the "Let's Encrypt" page the result is
"passed", but when I click on "Diagnostics" on the left of the page and
the diagnostics for all modules are displayed the letsencrypt module
diagnostics "failed".

Interestingly, for "Module diagnostics" this test fails:

Access URL on tcp4	failed

This is not the Local IP address returned by ppp (which is, as shown by the Network Manager log and ifconfig)

>From the "Firewall" page (/plinth/sys/firewall)

Web Server				Enabled
http					Permitted
Web Server over Secure Socket Layer	Enabled
https					Permitted

But this should not be a factor since the web server is running on the
freedombox itself, right?

/etc/apt/sources.list says "testing" and plith is 0.10.0 per the "About"
page.  The last software upgrade was done this morning.

What am I missing? Any hints out there?

There is also something weird that happened to the "Networks" page.
This apu1d4 box has 3 ethernet interfaces (WAN, enp3s0 and enp2s0) but
now there are 2 entries for enp3s0, one labeled "enp3s0" which is shown
correctly as "Active" and "FreedomBox LAN enp3s0" which is shown as
"Inactive".  When I clicked on "enp3s0" it said that this connection was
not known to the freedombox, it had firewall zone: none and a message
said that it should be deleted, so I did.  this caused a 500 internal
error message and ppp got disconnected.  When network manager went
through its paces, enp3s0 was again active and "FreedomBox LAN
enp3s0" was still inactive.  It looks like Network Manager prefers

Any hints about this issue would also be welcome.



More information about the Freedombox-discuss mailing list