[Freedombox-discuss] 403 error when connecting from the outside.

permondes - sagen sagen at permondes.de
Sun Nov 6 13:37:24 UTC 2016

Hi Augustine,

which service are you trying to access? E.g. Plinth cannot be accessed
from outside of your local network, this gives error 403, but e.g.
ikiwiki should work.

I also have now 2 network connections: eth0 active, Freedombox inactive.
This used to cause issues in the past and I had had to activate the
Freedombox one, but now it works this way, I have no idea why. Probably
it is not connected to your issue.


Am Samstag, den 05.11.2016, 23:58 -0400 schrieb A. F. Cano:

> Hi,
> I have tried to connect to the freedombox from the outside and I get a
> 403 Error: "you do not have permission..."
> The Dynamic DNS Client is set up (gnudip.datasystems24.net) to a domain
> under freedombox.rocks (HUGE thanks to whoever set this up!) and I do
> get to the freedombox.  The message is generated by plinth (it says at
> the bottom of the error page)  but I get the 403 message.  Then I
> obtained a certificate (through the "Certificates (Let's Encrypt)" page
> thinking that this might be the problem, but I still get the same error.
> Certifate status			Website Security
> Expires on Jan 28 18:27:00 2017 GMT	Enabled
> If I "Run Diagnostics" from the "Let's Encrypt" page the result is
> "passed", but when I click on "Diagnostics" on the left of the page and
> the diagnostics for all modules are displayed the letsencrypt module
> diagnostics "failed".
> Interestingly, for "Module diagnostics" this test fails:
> Access URL on tcp4	failed
> This is not the Local IP address returned by ppp (which is
>, as shown by the Network Manager log and ifconfig)
> From the "Firewall" page (/plinth/sys/firewall)
> Web Server				Enabled
> http					Permitted
> Web Server over Secure Socket Layer	Enabled
> https					Permitted
> But this should not be a factor since the web server is running on the
> freedombox itself, right?
> /etc/apt/sources.list says "testing" and plith is 0.10.0 per the "About"
> page.  The last software upgrade was done this morning.
> What am I missing? Any hints out there?
> There is also something weird that happened to the "Networks" page.
> This apu1d4 box has 3 ethernet interfaces (WAN, enp3s0 and enp2s0) but
> now there are 2 entries for enp3s0, one labeled "enp3s0" which is shown
> correctly as "Active" and "FreedomBox LAN enp3s0" which is shown as
> "Inactive".  When I clicked on "enp3s0" it said that this connection was
> not known to the freedombox, it had firewall zone: none and a message
> said that it should be deleted, so I did.  this caused a 500 internal
> error message and ppp got disconnected.  When network manager went
> through its paces, enp3s0 was again active and "FreedomBox LAN
> enp3s0" was still inactive.  It looks like Network Manager prefers
> "enp3s0"...
> Any hints about this issue would also be welcome.
> Thanks!
> Augustine
> _______________________________________________
> Freedombox-discuss mailing list
> Freedombox-discuss at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20161106/bb5a48c6/attachment.html>

More information about the Freedombox-discuss mailing list