[Freedombox-discuss] Olimex Lime 2 Gigabit Ethernet problem

Bastien Rocheron b at kuma.la
Sun Nov 20 11:58:55 UTC 2016


I am new to this list and to Freedombox. I am doing some research on
decentralizing and self hosting and have just started with freedombox.

I have searched the archives but maybe I have missed some threads so
please excuse me if I repost something and let me know.

I will start with installation as this is the stage I am in now.

I have installed freedombox on an Olimex box, a Lime 2 rev C.
This model is known to have an issue with the gigabit ethernet. When
used in gigabit mode, the performances are terrible, you can barely
connect via SSH...
A workaround is to connect to a 100 mbs port or manually set the speed
of eth to 100 mbs.

The real solution though is to apply a patch to u-boot.
I have just tried and can confirm that the latest image of freedombox on
the Lime 2 rev C is barely answering pings. And I can also confirm that
applying the patch solves it.

There is a thread on the Olimex forums here:

and a modified u-boot is available there as well:

I have tried both and only the mainline u-boot 2015.10-rc1 works in my case.

Their solution is quite convenient as it allows to replace u-boot
directly on a pre-installed sd card with dd.

But you may want to look at the source and apply the patch yourself as well.


More information about the Freedombox-discuss mailing list