[Freedombox-discuss] Re-SOLVED: Unattended updates not running

Petter Reinholdtsen pere at hungry.com
Wed Oct 5 18:50:30 UTC 2016

[znoteer at hailmail.net]
> This file belongs to apt.  However, it is not part of the .deb for
> version 1.3, which I am running.  A guy on #debian, also running apt
> 1.3, confirmed that /etc/cron.daily/apt wasn't present on his system. 
> Another guy running apt 1.0 did have the file on his system.

I suspect the source is this change in apt 1.2.10:

  * Use systemd.timer instead of a cron job (Closes: #600262, #709675, #663290)
    (LP: #246381, #727685)

James pointed this out in his email 2016-09-13.  I thus suspect there is
a problem with the systemd timer instead.  Apparently the cron file
should no longer be used.

When I check the status of that service on my freedombox, I notice it
haven't run for a long time:

  root at freedombox:~# systemctl status apt-daily.service
  * apt-daily.service - Daily apt activities
     Loaded: loaded (/lib/systemd/system/apt-daily.service; static; vendor preset: enabled)
     Active: inactive (dead) since to. 2016-09-22 17:03:30 UTC; 1 weeks 6 days ago
       Docs: man:apt(8)
   Main PID: 24188 (code=exited, status=0/SUCCESS)

  Warning: Journal has been rotated since unit was started. Log output is
  incomplete or unavailable.

I have no idea why.  I ran 'apt upgrade' manually today, and hope things
will improve now.

Happy hacking
Petter Reinholdtsen

More information about the Freedombox-discuss mailing list