[Freedombox-discuss] First experience

GDR! gdr at gdr.name
Mon Nov 6 13:28:54 UTC 2017


I'm not a novice user and I've dealt with all the problems listed, no
need for assistance, but I wanted to show what installing Freedombox is
like for a new user now. It's a QA report, not a rant.

I've downloaded Freedombox 0.9 image for Virtualbox. It imported nicely
and I was able to see the web interface. 

Problem 1: Chromium isn't happy to show http://freedombox/ and there's
no MOTD on screen suggesting which IP address to use.

Okay, so let's see what's available. I wanted to install Pagekite -

Problem 2: getting an error about dpkg being locked.

After logging in I figured out that unattended-upgrades is running.
When it was done, I tried installing the Pagekite again. 

Problem 3: after upgrade is finished, web interface is dead.

Okay, I'll try to reboot the VM then. 

Problem 4: after reboot, nothing is listening on ports 80 and 443

Looks like Apache failed to start, `systemctl start apache2` worked but
the web interface is very incomplete (missing the left column).
Something is very wrong. Turns out, package configuration wasn't
finished and `dpkg -a --configure` was needed, followed by `apt-get -f
install`. The failed packages were: freedombox-setup and plinth. After
that, I was able to see the web interface and install Pagekite.

Problem 5: /plinth/sys/pagekite/configure/ displays error 500 -
reported: https://github.com/freedombox/Plinth/issues/1119

I guess all of these problems, except for #5, could be solved by
releasing a new set of images - the current ones are from July 2016:

More information about the Freedombox-discuss mailing list