[Freedombox-discuss] FreedomBox doesn't appear on my network after installation

Sébastien Barthélémy barthelemy at crans.org
Sun Nov 11 23:19:06 GMT 2018

On Sun, Nov 11, 2018 at 12:58 PM Sébastien Barthélémy <barthelemy at crans.org>

> I think you can install an armbian recommended by Olimex, and "sudo apt
> install freedombox" from there.
> I have not tried yet, but will probably do.

I just gave it a try, it worked (as far as I tested).

Here a my notes (for my future self, don't follow them blindly). I used an
USB-serial cable because I have one, but using ethernet should also work.

1/ install armbian following instructions from

*  download Armbian_5.65_Lime2_Debian_stretch_next_4.14.78.7z from
* uncompress and copy it to SD card.
* plug the USB-Serial adapter, run kermit
* power the lime2, watch console logs while it boots
* login (root/1234), and follow instructions. I created a user "seb", maybe
I should have ctrl-c instead, because freedombox will also want to create a
* plug the ethernet cable, watch the board get an ip using journaltlf -kf
* update the OS:

    apt update && apt upgrade

* install to eMMC (use ext4 filesystem)

    nand-sata-install # do not poweroff at the end
    # clear the boot loader signature on the SD card
    dd if=/dev/zero of=/dev/mmcblk0 bs=1024 seek=8 count=1

* remove microSD card
* power the board, watch logs on console, login (either from console or

congrats, you're running (armbian flavor of) debian!

2/ install freedombox, following instructions from

   sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox-setup
   sudo touch /etc/apt/apt.conf.d/50unattended-upgrades #see below
   sudo /usr/lib/freedombox/setup | tee freedombox-setup.log

   last command failed with
   [2018-11-11 22:17:54,758] plinth.actions ERROR    Error executing
command - ['sudo', '-n', '/usr/share/plinth/actions/upgrades',
'enable-auto'], ,
   Error: Could not configure unattended-upgrades.
   until I ran "sudo touch /etc/apt/apt.conf.d/50unattended-upgrades"

reboot (once or twice, I'm not sure what happened) and plinth is now
accessible using a web browser.

3/ enjoy freedombox.

At this point I noticed that syncthing is not available on this plinth
version, and that armbian does not seem to provide buster images. I'm not
sure what I'll do.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20181112/f608747a/attachment-0001.html>

More information about the Freedombox-discuss mailing list