[Freedombox-discuss] FreedomBox doesn't appear on my network after installation

Sébastien Barthélémy barthelemy at crans.org
Sun Nov 11 11:58:44 GMT 2018

Hello Tunui, Adrian

On Sat, Nov 10, 2018 at 9:11 PM Adrian Gropper <agropper at healthurl.com>

> I completely sympathize with Tunui. I'm all for Olimex and everyone else
> seeking to license FreedomBox but our assumption that we need to use an
> enthusiast hardware config as an initial license model bears reflection.
> Nowadays, a 128x64 OLED display with driver costs less than $5 in volume. A
> WiFi and Bluetooth module costs less than $5. Together, they would add less
> than 20% to the cost of a Lime2. For that 20%, the increase in usability
> for novices and regular folks that want the benefit of Free Software would
> be immense.

FWIW, Tunui  issue is probably the same as mine (ethernet not getting an IP
though DHCP) a would not have been solved by an OLED display, which would
not have displayed any IP address.

An automatic redirection of logs to the UART would have helped me a lot (I
had to alter the image to add an user to enable logging in through the
console in order to read the logs).

On Sat, Nov 10, 2018 at 1:25 PM Tunui Franken <franken.tunui at gmail.com>
> wrote:
>> Hello everyone,
>> First of all I'd like to thank everyone for all the hard work on
>> FreedomBox. I think it's a great project and I hope it becomes truly
>> accessible to the average user, as I am.
>> It seemed on the main website, freedombox.org as an easy
>> download/install on supported SBCs so after reading around I went with
>> the LIME2. (with 4Gb eMMC)
>> Got the thing, assembled it, downloaded the latest testing img for LIME2
>> directly from freedombox.org, flashed a 16Gb SD card with it, plugged
>> everything in, waited for the lights on the Ethernet port to turn on
>> and... can't find the FreedomBox on my router's interface.
Same here, with a Lime2 16GB eMMC Rev.K.

I've waited some more for any eventual installs to finish, read what I
>> could online, but here's the thing : I'm not anywhere near being able to
>> understand all the technical stuff, it seems most people having issues
>> end up patching pieces of their software, but I can't do that.
>> I saw a discussion from a few days ago here :
>> https://salsa.debian.org/freedombox-team/freedom-maker/issues/148
Yes, this is the issue I have.

I understand it's a hardware problem due to PHY change in a revision at
>> some time,
I own the LIME2 revision K.
My ethernet hardware is working with the all the armbian images I tested,
but not with the freedombox (I tested stable and testing version).

So this is not (IMO) an hardware defect, it is an hardware change that
requires some change in software to work again.
(Source https://www.olimex.com/forum/index.php?topic=6734.0)

but apparently the last unstable img works.
I doubt it works on the latest hardware revisions of the LIME2.

So I went back to
>> freedombox.org and got the last nightly version for LIME2, still doesn't
>> work.
This confirms my suspicion.

I also tried the stable, who knows...
>> I know I might end up having to send the board back to Olimex, but if
>> anyone can help me before it comes to that (which won't mean I'll find
>> something working after btw) that would be awesome.
I think you can install an armbian recommended by Olimex, and "sudo apt
install freedombox" from there.
I have not tried yet, but will probably do.
I'm confident that at some point, the stock freedombox/debian image will
work again on the latest revisions of the LIME2.

I found the armbian do worth reading, even if you don't plan to use armbian

Thanks for your time, and I hope you'll be understanding, me being a
>> novice and all...
you're very welcome!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20181111/ebfd0f96/attachment.html>

More information about the Freedombox-discuss mailing list