[Freedombox-discuss] Freedombox went away, having trouble reviving

David Mintz david at davidmintz.org
Thu Dec 19 14:58:33 GMT 2019

This might be kind of off-topic in that the problem may go deeper than Freedombox, but...

I had my Freedombox running along fine for months, on a Raspberry Pi 3 B+ with an ethernet connection to a Verizon-provided router. All I was serving to the outside world was a little personal web site (Apache on port 433), and a Tor relay node using standard ports. A couple days ago  I noticed the web server not responding. With a desktop computer, I tried the router's web-based GUI and tried nmap to see if it was visible within the local network. This reported a Raspberry device but with a strange hostname I never heard of, much less assigned myself:  "hillo."  Tried connecting with it via SSH:  connection refused.

Figuring I had nothing to lose, I tried starting over:  burn a new image onto the card, reinstall, etc., per the instructions. Tried twice, in fact.  took care to give the new installation plenty of minutes to set up, then rebooted. The result is that I still can't see the device on the local network, can't connect to it.

Things I have yet to try include swapping out the ethernet cable and switching to another ethernet port on the router. I've never known these things to give out.

I have read that connecting a monitor via HDMI doesn't work. So I can't figure out how to figure out what's up with this Raspberry. I've considered trying just plain Debian from https://people.debian.org/~gwolf/raspberrypi/20190628/ but before I do, I though I might ask here for advice.


David Mintz
Capitalism has failed. https://wsws.org

More information about the Freedombox-discuss mailing list