[Freedombox-discuss] possible bug? tor installation does not open ports 9001, 9030?

David Mintz david at davidmintz.org
Wed Feb 6 16:32:55 GMT 2019

I posted the below message some days ago and got no response. Since then
I tried again, and managed to figure out a way -- if not THE way -- to
fix. I had previously installed the Tor package using Plinth and the web
interface, but my Tor ports were not reachable from the outside. Tried a
lot of things (in my naive way), no luck, gave up, started over with a
totally fresh OS installation, hoping to wipe the slate clean.
Next, I simply installed with `apt install tor`.  Again, port not
reachable errors.  Finally I figured out firewall-cmd enough to open
the ports manually (so to speak), with `firewall-cmd  --permanent
--add-port=9001/tcp --zone=internal`,  and again for port 9030. Now
my life is happy.
But that raises the question of whether the UI for Tor installation and
setup has an issue in Plinth. I am not sure, that's why I ask, but I
would have thought Plinth would have automatically done the firewall
config for me. So I looked for a bug report at
https://salsa.debian.org/freedombox-team/plinth/issues and could not
find anything relevant when filtering for "tor".
Any thoughts as to how to figure out whether there's an issue to report?
David Mintz
Capitalism has failed. https://wsws.org

On Tue, Jan 29, 2019, at 10:02 AM, David Mintz wrote:
> I've been happily running a Tor relay node -- the publicly published,> non-exit kind -- on a desktop machine, and decided it would be nice to> use FreedomBox on a SBC for that instead, to avoid the need to
> keep the> desktop powered up 24x7 just for the sake of the Tor node. So I got a> Raspberry Pi 3 B+ and installed FreedomBox per the instructions -- so> far so good. This is behind a Verizon router with port forwarding
> configured appropriately.
> Then I tried installing Tor on the Raspberry through plinth, and
> updating the port forwarding accordingly (i.e., disabled the rule that> forwarded to the desktop box and added one to forward to the
> FreedomBox;> I'm confident I got my IP addresses and port numbers right.) I got
> errors to the effect that my Tor was not reachable from the outside. I> tried all kinds of fiddling with systemd configs, with tor
> config files,> etc., to no avail.
> Please forgive me for the sin of not providing actual error output,
> configurations, a detailed narrative of what I did, etc. I got
> impatient> and re-installed everything, and went back to running Tor on my
> desktop> for now, and all that information is unavailable. I just want
> to ask as> a general question whether I should expect the following alternative
> strategy to work:
> (1) disable Tor on the desktop and remove port forwarding rules.
> (2) enable port forwarding to the FreedomBox, consistent with the
>     ORPort> and DirPort numbers set in the tor config
> (3) install tor from the command line according to
> https://www.torproject.org/docs/debian.html.en
> (4) copy my torrc file over from the desktop and restart the service

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20190206/85b5d7c6/attachment.html>

More information about the Freedombox-discuss mailing list