[Freedombox-discuss] Searx stopped working: Error! search error

A. F. Cano afc54 at comcast.net
Wed Dec 16 02:55:15 GMT 2020

On Tue, Dec 15, 2020 at 08:00:36PM -0500, James Valleroy via Freedombox-discuss wrote:
> On 12/14/20 11:02 PM, A. F. Cano wrote:
> \> Evan after a reboot searx comes back immediately with an "i" in a circle
> > and "Error! search error". as soon as I hit enter or click on the
> > magnifying glass.  I didn't see anything about searx in the release
> > notes for version 20.20, so I wonder if this is related to the
> > not-upgraded python3-django as seen above.
> > 
> > Any hints, anyone?
> I assume you are running testing/bullseye, correct?


> You could try to update the search engines list for searx, by running the following command as root:
> # /usr/share/plinth/actions/searx setup

Didn't fix it.  No error returned, no output from that command at all.
Prompt just came back after a few seconds.

Tried searx from konqueror and firefox.  Same result.

Incidentally, immediately after the error appears the "Search for..."
text field is cleared.

> This was handled for users running testing/bullseye before, in
> FreedomBox 20.3 [1]. But if you were running stable/buster then,
> and later did a dist-upgrade to testing/bullseye, then the list

No.  This was always a testing/bullseye FreedomBox, on an apu1d4.

> of search engines needs to be updated again. I recently found this
> and am working on an implementation for the automatic dist upgrade
> support in FreedomBox [2].
> [1] https://salsa.debian.org/freedombox-team/freedombox/-/merge_requests/1722
> [2] https://salsa.debian.org/freedombox-team/freedombox/-/merge_requests/1966
> --
> James

Maybe this is related to the occasional failures (no results found) I
have seen before.  In those cases, hitting <RETURN> again and again
eventually brings up the results page.  Maybe now it generates a
consistent error.  Could this be?

Anysay, thanks for replying.  Any other suggestions?


More information about the Freedombox-discuss mailing list