[Freedombox-discuss] Cannot connect to radicale from phones after installing new image.

A. F. Cano afc54 at comcast.net
Mon Dec 20 03:02:52 GMT 2021


This used to work with the old image (testing), but then I created a new
image (stable).  The kde software had no problems (Kaddressbook and
Korganizer) on multiple computers, but the 2 phones that used to work now
can't connect.

At first I got

javax.net.ssl.SSLHandshakeException: javax.net.ssl.SSLProtocolException: 

This page:


says it's an incompatible version of the protocol, but it used to work.

Then, per some other page that advised to delete the local user and
re-create it, i did so.

Originally I entered (into DAVDroid) with the "Login with URL and user
name" option:

URL: https://<IPv4 address>/radicale/<user>/
user name <user>
password: <password>

and it worked.  Now I get a popup on the phone that says:

Configuration Detection
Couldn't find CalDAV or CardDAV service.
View logs	ok

In the log files, down a few lines, I see the dreaded

The directories on the FreedomBox are addressbook.vcf and calendar.ics,
under /var/lib/radicale/collections/collection-root/<user>.

The phones are running android 4.2.2 and DAVDroid.  The new DAVx can't
run on these old systems, but DADDroid used to work just fine.

Can someone suggest what might have changed?  Is this s case of the
protocols on the FreedomBox being upgraded and the older version on the
phones not being able to connect? If so, is there a way to tell the
Freedombox to use the older protocols?

I'm trying to upgrade the phones, but android is so locked up in the
more modern one that there appears to be no path to upgrade, the other
one runs an old version of Cyanogenmod but this one being my main phone,
I really don't want to upgrade it until I have the other one working.

When I first configured DavDroid on the newer phone, it transfered
everything from the radicale server, but now that I deleted the local
user, there's nothing there anymore.

On the older phone attempting to synchonize gives the error:

Service Detection Failed
Couldn't refresh collection list

WIth the same error messages described above.

Any hints will be greatly appreciated.  Thanks.


More information about the Freedombox-discuss mailing list