[Freedombox-discuss] Fwd: Request to check rrror with Freedombox

Sunil Mohan Adapa sunil at medhas.org
Fri May 14 03:39:49 BST 2021

On 13/05/21 9:31 am, Navi Singh wrote:
> Hi Dear,
> Greetings!!
> Currently, I'm testing freedombox with my Raspberry pi 400, and first of
> all, I would like to explain about my freedombox setup.
> 1. SD card with UEFI Firmware 
> 2. USB type 3.0 with freedombox image
> 3. Ethernet Cable 
> 4. LED with HDMI cable. 
> the first time, it is being executed, but when I try to restart with
> both SD card and USB. its reaches to the *grub recuse>*
> *with Grub rescuse > * if I use ls, set root, set prefix etc it is being
> done successfully, but again when I tried to do *insmod normal *and
> *normal,* both are showing an error. 

You may be facing a bug in grub[1]. Before you reboot, please try
installing 'shim-signed', 'shim-helpers-arm64-signed',
'shim-signed-common' and 'shim-unsigned' packages. If that does not
work, please uninstall the grub* packages and re-install them. This
worked for me.

> So my question is that, how can I resolve the restart case, and how can
> I put UEFI firmware & freedombox USB in a single drive, because there is
> no response if I remove SD card. 

The SD contains the UEFI firmware in the format understood by Raspberry
Pi. The USB drive contains EFI partition and the root partition. You can
to combine them manually by copying the EFI and root partitions to SD
card. It is likely to work without any further changes.

On official images, we can't distribute the UEFI firmware due to be
binaries it it and we are trying not to create a separate image for each
of the single board computers.

> http://deb.debian.org/debian/pool/main/p/python-colorama/python3-colorama_0.4.4-1_all.deb
> <http://deb.debian.org/debian/pool/main/p/python-colorama/python3-colorama_0.4.4-1_all.deb>
> Could not resolve 'debian.map.fastlydns.net
> <http://debian.map.fastlydns.net>' Cannot initiate the connection to
> deb.debian.org:80 <http://deb.debian.org:80> (2a04:4e42:48::644). -
> connect (101: Network is unreachable) Could not connect to
> deb.debian.org:80 <http://deb.debian.org:80> (,
> connection timed out E: Failed to fetch

If your FreedomBox is able to access network in general but not able to
do install apps, then it could be a problem with IPv6 configuration in
your network. Try setting IPv6 configuration to "Ignored" using
FreedomBox interface, nmtui tool or nmcli too.

1) https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=984760


More information about the Freedombox-discuss mailing list