[Freedombox-discuss] Is there some mailing list that discusses matrix clients, specifically element desktop?

Geert Stappers stappers at stappers.nl
Sun May 16 21:31:32 BST 2021

On Sun, May 16, 2021 at 03:44:17PM -0400, A. F. Cano wrote:
> On Sat, May 15, 2021 at 09:31:56AM +0530, Joseph Nuthalapati wrote:
> > On 14/05/21 1:43 am, A. F. Cano wrote:
> > > hi,
> > > 
> > > I've been using Element desktop successfully for months with my
> > > FreedomBox-based Matrix-synapse server.  Since last week I get
> > > no video and can't connect to any room.  The camera is known though, if
> > > I click on the ^ of the video icon, I see the picture from the camera
> > > but both the camera and microphone have a slash through them.  Every few
> > > seconds it sys "you have been disconnected".  Nothing that I've tried
> > > gets rid of the problem.  At the top of the video field it says
> > > $roomName and next to that AUD (no video), then room name gets replaced
> > > by "Jitsi Conference Bashful Strange Cheese".  If I hang up (red phone
> > > icon inside the video field), get out of jitsi and click on the camera
> > > icon at the top, it says "Call in Progress  A call is currently being
> > > placed!" which is obviously not true.  Rebooting the FreedomBox and the
> > > computer that runs Element Desktop have no effect.  Element got upgraded
> > > to 1.7.27 but the problem occurred even before that.  Text chat works
> > > fine.  Any suggestions?
> > > 
> > > I've been looking and looking for a users/support mailing list for
> > > Element desktop and have found nothing.  Can someone point me to one?
> > > 
> > 
> > There doesn't seem to be a dedicated Matrix room for Element desktop. I only
> > found this general support email: support at element.io
> > 
> > 
> > Troubleshooting:
> > 
> > Server:
> > 
> >   As mentioned in the manual[1], Element handles audio/video calling for
> > rooms with one-to-one conversations (a.k.a Direct Messages in the mobile
> > app) and with rooms with larger groups differently. It uses the configured
> > STUN/TURN server for the former and a Jitsi Meet server for the latter
> > (default server: jitsi.riot.im). It is worth checking both the cases. Fixing
> > the former case is within your control - check whether the Coturn app is
> > running on your FreedomBox. Configuring your Matrix Synapse installation to
> > use a different Jitsi Meet server is not yet implemented in FreedomBox
> > (issue #2064).
> When I last tried with other people in the same "chat room" I was the
> only one having this problem, so it's unlikely it's a server problem.
> Since then I've installed Element on 2 other computers with the
> following results:
> On computer 1, it works.  I'm not sure what's different about this
> computer.  Same OS version, same element version.
> On computer 2, I get a pop-up saying "Call in progress A call is
> currently being placed", which is the same error I get in the original
> computer when I click on the camera icon at the top.  There used to be
> another "hang up" button next to the video field (separate from the one
> inside the video field to hang up the video conference) that did more
> than just turning off the camera but this button is gone.  I think this
> latter button did more than the in-field hang up button.

I, sysadmin slash network guy, would check network traffic.

> > Client:
> > 
> >   It could also be a client issue. One way of figuring this out is to
> > install a previous version of Element desktop and see if the problem still
> > exists. I don't use Element desktop myself, but I believe it's an
> > Electron-based application (basically a Chromium browser running a single
> > web app). It's possible that the application no longer has the permission to
> > access your camera.
> Good to know all this, but access to the camera is not the issue.  If I
> click on the ^ next to the in-video-field icon of the camera (that has a
> "\" through it) a little rectangle opens up where I can see the video
> from the camera.
> >   Another way of making sure that it's a client issue is to use try using
> > app.element.io in your browser. Give it permission to access your camera
> > when prompted.
> > 
> >   This is less likely, but maybe your camera is not working anymore. Test
> > this with a camera app e.g. Cheese on Debian.
> Camera works fine with Cheese.
> > 
> > 1. https://wiki.debian.org/FreedomBox/Manual/MatrixSynapse#Setting_up_Audio.2FVideo_calls
> This is interesting, but given that I've been using element for months
> now until this problem developed in the last month, and now element on
> another computer doesn't have this problem, I don't think it's a
> configuration issue on the matrix-synapse server on the freedombox.
> I also created new users, in case the issue was about the specific user,
> but a new user has the same problem.  It does appear though that this
> only happens in one specific room, but restarting the matrix-synapse
> server, or element doesn't do anything to fix the problem.  Neither does
> logging out/in.
> In any case, thanks for taking the time to respond.
> I'll keep investigating.

Hopefully can these links help
* https://nl.webcamtests.com/
* https://nl.mictests.com/

Yes, I am from  .nl   Find in the upper right corner
of those testwebsite a selector for other languages.

Geert Stappers
Silence is hard to parse

More information about the Freedombox-discuss mailing list