[Freedombox-discuss] Issue with FreedomBox stable first boot on Konqueror, and more.

A. F. Cano afc54 at comcast.net
Tue Nov 16 00:14:23 GMT 2021

Hi everyone,

All this applies to the apu1d version of FreedomBox.

Since my FreedomBox (testing) got progressively worse and worse, first
due to no packets going through from the inside, resulting in no email
and http only being possible because that was going through privoxy, and
then the issues brought by 21.13 (no ssh - it couldn't be enabled at
all, no cockpit - same), I decided to make an image of the stable

I first tried to make a clean image of testing, with


and failed.  I could not access the box at all the way the instructions
say should be possible (https://freedombox.local).  Maybe because my
internal networks use static IPs, although mDNS should be running.  Then
I tried adding the files

FreedomBox LAN enp2s0
FreedomBox LAN enp3s0
FreedomBox WAN

from /etc/NetworkManager/system-connections to the same directory after
mounting the newly created image.  Now I could ping the FreedomBox and
packets were going through, so I could receive email at least, but there
was no way to see the firstboot setup screen.  Does the same issue that
afflicts 21.13 also cause the above image not to work?

So, on to burn an image of


I did this on the only remaining SD card I had handy, which was a 4GB
one, and got this:

3953131520 bytes (4.0 GB, 3.7 GiB) copied, 184 s, 21.5 MB/s
dd: error writing '/dev/mmcblk0': No space left on device
3775+0 records in
3774+0 records out
3957325824 bytes (4.0 GB, 3.7 GiB) copied, 578.746 s, 6.8 MB/s

Looks like the last block didn't copy.  Probably not fatal.

Then booted the stable image.  I could access the FreedomBox by the
static name but not by the mDNS one (<name>.local).  Got to the
firstboot setup and got as far as the "Frequent Feature Updates" screen
(with Konqueror) and then the "Next" button wouldn't work.  Luckily
tried with firefox and it did work, so it's now "Updating, please
wait..."  Whan that finished, even without installing any apps, I'm
already getting a "Low disk space" warning, and then the first app I
tried to install resulted in this:

Error installing application: Error during installation dpkg: unrecoverable fatal error, aborting: unable to create '/var/lib/dpkg/updates/tmp.i': Input/output error quota not working (qgroup not set) Snapshot '3' not found. quota not working (qgroup not set) E: Sub-process /usr/bin/dpkg returned an error code (2) E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

I did the "sudo dpkg --configure -a" and it finished very quickly.

Looks like it's time to find a larger SD card.

Deleted the snapshots and that cleared up some space, but then got an
error 500 during searx installation.  Going back to the same page it
seems that the installation is proceeding, so it might have been a
transient error.

Then tried to restore the remote backup I did a few days ago from the
monstly-non-working testing image.  after entering the SSH repository
path (<user>@<IP>:~/path/to/repo) and entering the password I use to
login via ssh, and selecting "Encryption None", Create Location results
in this error:

 Added new remote SSH repository. SSH host already verified. ('backups', '', 'Warning: Attempting to access a previously unknown unencrypted repository!\nDo you want to continue? [yN] Aborting.\nCache initialization aborted\nTraceback (most recent call last):\n File "/usr/share/plinth/actions/backups", line 310, in <module>\n main()\n File "/usr/share/plinth/actions/backups", line 306, in main\n subcommand_method(arguments)\n File "/usr/share/plinth/actions/backups", line 114, in subcommand_info\n run([\'borg\', \'info\', \'--json\', arguments.path], arguments)\n File "/usr/share/plinth/actions/backups", line 296, in run\n return subprocess.run(cmd, check=check, env=env, **kwargs)\n File "/usr/lib/python3.9/subprocess.py", line 528, in run\n raise CalledProcessError(retcode, process.args,\nsubprocess.CalledProcessError: Command \'[\'borg\', \'info\', \'--json\', \'/media/2977c0dc-466f-11ec-a4e1-000db93f92a8\']\' returned non-zero exit status 2.\n') Repository removed. 

And it goes back to prompting me for the SSH repository path.  It
appears that it is not possible to restore the backup I made in the
mostly non-working FreedomBox.

And of course, I'm geting a "You have 173.5 MiB available to restore a
backup.  Exceeding this limit can leave your FreedomBox unusable".

Entering all the users, passwords and configuration manually is going to
be extremely tedious and error-prone.  Is there anything I can do to fix
this error in the restore procedure?

I also have a theoretical question:  How does restore handle config data
from an app not yet installed? would it mess up the configuration of the
app once it's installed? or (like seems to be the case for matrix) does
the domain name (in my case dynamic) need to be working before matrix
can be set up?  Apparently this needs to be set up in the initial
installation and cannot be changed later.

Any help gratefully appreciated.  Thanks.


More information about the Freedombox-discuss mailing list