[Freedombox-discuss] Dependency problem for matrix-synapse.

Diederik de Haas didi.debian at cknow.org
Wed Jan 12 16:47:30 GMT 2022

On woensdag 12 januari 2022 15:19:25 CET A. F. Cano wrote:
> I noticed that matrix-synapse was not upgrading with aptitude (the
> auto-upgrade had not had an upgrade in days, possibly a week) and it

That would concern me too, but that's because I run Sid ...

> turns out it needed python3-authlib and python3-jwt.  Installed those
> manually and then tried again.  It now needs pythno3-frozendict, which
> is already installed (at version 3.38.0-2).  It now breaks
> matrix-synapse-ldap3.  Removed it.  Reinstalled it.  Actually 2 packages
> were re-installed, but it's back at "Breaks matrix-synapse-ldap3 (<
> 0.1.3-2-)".

It would really help if you could provide the full log of what you did and the 
resulting output. Now we're left with (mostly) guessing.

What may help is the output of the following commands:
- aptitude versions matrix-synapse
- aptitude why python3-authlib
- aptitude why python3-jwt
- aptitude search ~b

The 2 'why' queries are because those packages are *suggested* by matrix-
synapse, so I'd like to know what makes them needed.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: This is a digitally signed message part.
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20220112/a446c3fd/attachment.sig>

More information about the Freedombox-discuss mailing list