[Freedombox-discuss] Very strenge... "Shaare link" button (Shaarli) and docs.freedombox.org

Znoteer znoteer at mailbox.org
Sat Oct 29 18:20:34 BST 2022

On Fri, Oct 28, 2022 at 09:46:59PM -0400, A. F. Cano wrote:
> On Fri, Oct 28, 2022 at 05:29:06PM -0400, Znoteer via Freedombox-discuss wrote:
> > Hi,
> > 
> > On Fri, Oct 28, 2022 at 04:02:37PM -0400, A. F. Cano wrote:
> > > HI,
> > > 
> > 
> > > 250+ links already but encountered this very strange situation:  The
> > > "Shaare link" button, on firefox, does nothing (doesn't work) only when
> > > trying to enter https://docs.freedombox.org.  All the other links I've
> > 
> > Works for me.  I tried adding the shaare 2 ways. First, by using the +Shaare
> > button on the Shaarli interface
> Ok, tried that and it worked.  This is the +Shaare menu entry in the
> menu at the top with the green background.  I had to copy/paste the url
> into the field that popped up.

Yes, one has to copy/paste when using this method.
> > and second, by clicking the the green star that the firefox shaarli addon
> > puts in the bar where the location field is. (I wasn't sure which button
> > you meant.)
> Mmm... I don't see a green star.  I see a blue star, which at first I
> thought was the regular way that firefox saves a bookmark in its own

Yes, that blue star is FF's own "save link" button. I added a Firefox extension for adding shaares (https://addons.mozilla.org/-/firefox/addon/shaarli/). It adds the green outline of a star on the same bar as the blue star, but further to the right. See the screenshot. If you didn't mean this green star in your original post, which button were you referring to?

> internal structure, but when clicking on it it drops down a mini-screen
> with the freedombox logo, with the usl already filled in.  Even though
> the "Show editor when saving" is checked, clicking "Save" does nothing.

That little miniscreen is the editor. It allows one to modify (edit) the url and title that are there by default. (I seem to have lost it in the screen shot above. Normally it's at the right end of the address field.)


znoteer at mailbox.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot_add-shaare-button_2022-10-29_13-03-46.png
Type: image/png
Size: 75587 bytes
Desc: not available
URL: <http://alioth-lists.debian.net/pipermail/freedombox-discuss/attachments/20221029/7f508aa6/attachment-0001.png>

More information about the Freedombox-discuss mailing list