[Freedombox-discuss] Very strenge... "Shaare link" button (Shaarli) and docs.freedombox.org

A. F. Cano afc54 at comcast.net
Sat Oct 29 02:46:59 BST 2022

On Fri, Oct 28, 2022 at 05:29:06PM -0400, Znoteer via Freedombox-discuss wrote:
> Hi,
> On Fri, Oct 28, 2022 at 04:02:37PM -0400, A. F. Cano wrote:
> > HI,
> > 
> > First of all, I'm very happy that Shaarli works again.  I've imported
> Me too!
> > 250+ links already but encountered this very strange situation:  The
> > "Shaare link" button, on firefox, does nothing (doesn't work) only when
> > trying to enter https://docs.freedombox.org.  All the other links I've
> Works for me.  I tried adding the shaare 2 ways. First, by using the +Shaare
> button on the Shaarli interface

Ok, tried that and it worked.  This is the +Shaare menu entry in the
menu at the top with the green background.  I had to copy/paste the url
into the field that popped up.

> and second, by clicking the the green star that the firefox shaarli addon
> puts in the bar where the location field is. (I wasn't sure which button
> you meant.)

Mmm... I don't see a green star.  I see a blue star, which at first I
thought was the regular way that firefox saves a bookmark in its own
internal structure, but when clicking on it it drops down a mini-screen
with the freedombox logo, with the usl already filled in.  Even though
the "Show editor when saving" is checked, clicking "Save" does nothing.

When I try to save other urls that have already been saved, I normally get
the regular page with "Edit Shaare" instead of "New Shaare".

This blue star method doesn't work with other pages that have already
been saved.  It doesn't work with new pages either.  Testing as I write

The + Shaare link button which is on the bookmarks toolbar always works,
with the exception of the one link (https://docs.freedombox.org).

> * Firefox 106.0.2 64-bit

Firefox 102.4.0esr-1-deb11u1, from Debian stable.

> * I added tags "freedombox" and "documentation"

The tags, when it works, work fine.

> * shaarli here is configured to make shaares private by default. I kept the default

Same here.

> * I accepted the title that shaarli scraped from the page

Same here.

> How does that compare with your setup?

Pretty similar.  Older firefox here but at least the boomkarks toolbar
button works reliably except for the one link that caused me to write the
original post.  Since I now have the other method (the +Shaare on the
green menu of the shaarli page itself) that has worked with the one url
that didn't with the bookmarks toolbar button, crisis averted.

It is strange that the blue star method doesn't work at all.

> -- 
> Znoteer
> znoteer at mailbox.org

Thanks for replying.  Now I know there is an alternative way that worked
with this recalcitrant url.


More information about the Freedombox-discuss mailing list