[Fusioninventory-user] First install, some question.

Marco Gaiarin gaio at sv.lnf.it
Wed May 30 15:13:43 UTC 2012

I'm a long-term GLPI user, and i've managed my inventory manually 'til

I've tried to install FI on a debian lenny box, using GLPI 0.80.7, using
clerly version 80+1.3.

Installation went smoothly, i've installed for test an agent on the
server itself and on a windows box, and all work as expected.
Then i've tried to use SNMP to tackle with printers and switches, and
here real trouble begun.

Some question.

1) running the agent on linux (i restate, debian lenny) i've had to
ignore ssl verification, logs say me:

 [Tue May 29 17:29:12 2012][error] Cannot establish communication with `https://helpdesk.ct.lnf.it/glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php: 500 Bad SSL certificate subject: '/C=IT/ST=Salerno/L=Cava De' Tirreni/O=Associazione La Nostra Famiglia/OU=Cava De' Tirreni/CN=meti.ct.lnf.it' !~ //CN=(helpdesk|\*)\.ct\.lnf\.it($|\/)/`

seems to me an erratic regexp/match; indeed, windows client connect
without trouble at all...

2) after running the agent, software got collected including ALL DEBIAN
 PACKAGE and windows service packs.
Ok, no trouble at all, but i thinked that i will tag automatic added
software with some data (software category?) so i can clearly
distinguish auto added software from manually added ones.
I've not found a way to associate software category...

3) installing and running SMTP agent lead me to trouble, that apache
error log report as:

 [Tue May 29 17:11:42 2012] [error] [client] PHP Fatal error:  Class 'PluginFusinvsnmpModel' not found in /usr/local/share/glpi/plugins/fusinvsnmp/install/install.php on line 94, referer: https://helpdesk.ct.lnf.it/front/plugin.php
 [Tue May 29 18:22:15 2012] [error] [client] PHP Fatal error:  Class 'PluginFusinvsnmpImportExport' not found in /usr/local/share/glpi/plugins/fusinvsnmp/inc/model.class.php on line 371, referer: https://helpdesk.ct.lnf.it/front/plugin.php
 [Wed May 30 11:02:55 2012] [error] [client] PHP Fatal error:  Class 'PluginFusinvSNMPConfig' not found in /usr/local/share/glpi/plugins/fusioninventory/ajax/configuration.tabs.php on line 99, referer: https://helpdesk.ct.lnf.it/plugins/fusioninventory/front/configuration.form.php
 [Wed May 30 12:47:22 2012] [error] [client] PHP Fatal error:  Class 'PluginFusinvSNMPConfig' not found in /usr/local/share/glpi/plugins/fusioninventory/front/configuration.form.php on line 69, referer: https://helpdesk.ct.lnf.it/plugins/fusioninventory/front/configuration.form.php

doing some grep around lead me to missing include('') on the php
code... i've tried to add to the file the correct include, but (apart
that new missing include appears...) SNMP seems not to work.

Eg, i've tried to configure a switch using the correct MIB entry (HP
J9085A, 9807323), the switch have SNMP enabled, eg have:

	snmp-server community "public" Unrestricted

but nothing happens.

What i'm missing? Thanks.

dott. Marco Gaiarin				    GNUPG Key ID: 240A3D66
  Associazione ``La Nostra Famiglia''                http://www.sv.lnf.it/
  Polo FVG  -  Via della Bontà, 7 - 33078  -  San Vito al Tagliamento (PN)
  marco.gaiarin(at)sv.lnf.it	  tel +39-0434-842711  fax +39-0434-842797

	(cf 00307430132, categoria ONLUS oppure RICERCA SANITARIA)

More information about the Fusioninventory-user mailing list