[Nut-upsdev] Re: [Nut-upsuser] Atlantis-Land UPS with Cypress

Peter Selinger selinger at mathstat.dal.ca
Tue Dec 13 16:29:14 UTC 2005

Hi Max,

ngpost1 wrote:
> Hello Peter!
> Peter Selinger wrote:
> > This is useful information. I don't think the device is currently
> > supported, but the information printed above is enough to write a
> > subdriver for it. Note that the purpose of the "-x generic" option is
> > precisely to produce this output. 
> [...]
> >>    Apparently the UPS is recognized but no communication is 
> >> occurring. What else? lsmod shows the yealink driver loaded. I 
> >> attached the lsusb output.
> >>    If I ls the /dev directory, there are no ttyUSBxx nodes. Only 
> >> tty's and ttySxx. I believe there should be a ttyUSBsomething being 
> >> created, and this should be entered in the ups.conf file.
> >>     
> >
> > No, USB devices are handled through /proc/bus/usb, not /dev/tty*.
> >   
>   Two questions: first of all, in a situation like mine (HID UPS) and 
> assuming the UPS is actually supported, what are you supposed to have in 
> the "port" entry in the ups.conf file? 

It does not matter; the entry is ignored by the newhidups driver. The
"port" entry must be present but is ignored. See the newhidups man page.

> I tried the obvious at first 
> (ttyS*), then tried /proc/bus/usb/001 (taken from my system) a minute 
> ago after reading your reply. No joy. "No matching USB/HID UPS found" 
> message after I "upsdrvctl start".

USB devices are matched by their vendorid, not by their device file.
>   Second: this UPS comes with the UPSilon2000 software from Megatec, and 
> Megatec protocol is supported by NUT (or is it the RS-232 version being 
> supported?), right?

As far as I know, only the serial protocol is currently supported for

-- Peter

More information about the Nut-upsdev mailing list