[Nut-upsdev] [nut-commits] svn commit r1043 - in trunk: . docs

Arjen de Korte nut+devel at de-korte.org
Sun Aug 12 15:10:52 UTC 2007

>> > I think the following three lines are typos, should be alarm_set():
>> >
>> >      status_set("Replace battery!");
>> >      status_set("Awaiting power!");
>> >      status_set("Emergency stop!");
>> Quite right. I will change this anyway, since I don't like the
>> requirement that alarms *must* be defined in usbhid-ups. Subdrivers
>> should be able to set their own alarms (besides the ones that can be
>> considered 'common'), without the need of modifying usbhid-ups. I
>> already have an idea how to do this and will post a first go at this
>> later today.
> This is fine, as long as no logic is needed to combine flags. That
> would have to be dealt with in usbhid-ups.c, see my previous
> message. I suppose that could still be done using the existing
> status_bit_t mechanism.

We might run out of status bits however. If I continue with the present
speed of adding alarms, we would need more than the 32 bits we have
available right now by the end of the week. :-)

> Moving most alarms to subdrivers will also have the effect of
> discouraging uniform alarm messages. I think they should be uniform at
> least within a given driver (usbhid-ups). For example, Belkin and
> Tripplite both have AWAITINGPOWER.

The problem I have with that, is that some UPSes may have flags that are
not defined by the HID Power Devices document you mentioned earlier. I
would prefer if we kept those in the subdrivers.

Best regards, Arjen

More information about the Nut-upsdev mailing list