[Nut-upsdev] [nut-commits] svn commit r1264 - in trunk: . drivers m4 scripts/hal

Charles Lepple clepple at gmail.com
Sat Feb 2 05:48:14 UTC 2008

On Feb 1, 2008 6:11 PM, Arnaud Quette <aquette at alioth.debian.org> wrote:
> Author: aquette
> Date: Fri Feb  1 23:11:33 2008
> New Revision: 1264
> Log:
> fix HAL support installation [Alioth Bug #304156]


I tried to fix some of the errors that I was seeing in buildbot, but I
still get the following error on "make distcheck", and I don't know
how to fix it:

test -z "" || mkdir -p -- ""
  /bin/bash ../libtool --mode=install /usr/bin/install -c
'hald-addon-usbhid-ups' '/hald-addon-usbhid-ups'
libtool: install: `' must be an absolute directory name
Try `libtool --help --mode=install' for more information.
make[3]: *** [install-halexecPROGRAMS] Error 1
make[3]: Leaving directory `/home/clepple/dl/NUT/trunk/nut-2.3.0/_build/drivers'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/clepple/dl/NUT/trunk/nut-2.3.0/_build/drivers'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/clepple/dl/NUT/trunk/nut-2.3.0/_build'
make: *** [distcheck] Error 2

Do we need to modify the arguments passed to ./configure during "make
distcheck" for the HAL install process?

- Charles Lepple

More information about the Nut-upsdev mailing list