[Nut-upsdev] Patch to support GE EP series

Arjen de Korte nut+devel at de-korte.org
Fri Apr 15 06:36:35 UTC 2011

Citeren Danilo Godec <danilo.godec op agenda.si>:

> The UPS has both RS232 and USB connection. To use the RS232 connection,
> I had to use the 'cablepower = none' as the UPS is using only RX, TX and
> GND pins.

If the UPS really only uses the RX and TX pins, the setting of  
'cablepower' is irrelevant.

> So my 'usp.conf' was a bit like that:
>> [myups]
>>         driver = blazer_ser
>>         port = /dev/ttyS0
>>         cablepower = none
>>         desc = "Local UPS"
> To use the USB connection required a bit more work, but I eventually
> found out what it takes:
>> [myups]
>>         driver = blazer_usb
>>         port = /dev/ttyS0  # probably irrelevant
>>         vendorid = 14f0
>>         productid = 00c9
>>         subdriver = phoenix
>>         desc = "Local UPS"

Have you also tried *all* the other subdrivers? The 'phoenix'  
subdriver was an early attempt to work around some issue we found in a  
particular USB to serial converter, which later turned out to be  
better solved in the 'ippon' subdriver. Make sure you have also tested  
the latter.

> I also made a patch so I don't need to define 'vendorid', 'productid'
> and 'subdriver' in config, but since I'm not a programmer, the patch is
> mostly 'guesswork'. The patch is against nut-2.6.0 release.
> I hope this list accepts attachments...

We do. I'll commit the changes to the development version once we've  
ironed out the last things here.

Best regards, Arjen
Please keep list traffic on the list (off-list replies will be rejected)

More information about the Nut-upsdev mailing list