[Nut-upsuser] tripp lite omnivs1500xl and usb

Bryan Olmstead olmstead at b2mail.net
Sat Aug 6 16:30:30 UTC 2005

i just purchased a tripp lite OMNIVS1500XL and have been attempting to get 
it working with the usb drivers since it doesn't have a serial port.  it 
hasn't been anywhere near successful and i was hoping someone might be 
able to point me in the right direction.

i run gentoo and this is what i currenlty have installed:

   nut 2.0.2
   libusb 0.1.10a  (gentoo modified)
   usbutils 0.11-r5  (gentoo modified)
   kernel (gentoo modified)

and i built nut with these configure options:

   ./configure --with-user=nut --prefix=/usr/local/nut-2.0.2

lsmod shows that i do have the usbhid in (i have to double check this all 
the time <g>):

   Module                 Size   Used by
   usbhid                 32992  0
   usblp                  12032  0
   ehci_hcd               38344  0
   ohci_hcd               26372  0

lsusb shows that the tripp lite is seen on the usb bus:

   Bus 003 Device 029: ID 03f0:1017 Hewlett-Packard
   Bus 003 Device 028: ID 0409:0058 NEC Corp. HighSpeed Hub
   Bus 003 Device 015: ID 09ae:0001 Tripp Lite
   Bus 003 Device 003: ID 0409:0058 NEC Corp. HighSpeed Hub
   Bus 003 Device 001: ID 0000:0000
   Bus 002 Device 001: ID 0000:0000
   Bus 001 Device 001: ID 0000:0000

and it appears in dmesg:

   usbhid 3-2.1:1.0: usb_probe_interface
   usbhid 3-2.1:1.0: usb_probe_interface - got id
   drivers/usb/core/file.c: looking for a minor, starting at 96
   hiddev96: USB HID v1.00 Device [TRIPP LITE TRIPP LITE OMNIVS1500XL]
   on usb-0000:00:02.2-2.1
   usbcore: registered new driver usbhid
   drivers/usb/input/hid-core.c: v2.01:USB HID core driver

and if i cat /proc/bus/usb/devices this is the entry for the tripp lite:

   T:  Bus=03 Lev=02 Prnt=03 Port=00 Cnt=01 Dev#= 15 Spd=1.5 MxCh= 0
   D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
   P:  Vendor=09ae ProdID=0001 Rev= 0.01
   S:  Manufacturer=TRIPP LITE
   S:  Product=TRIPP LITE OMNIVS1500XL
   C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr= 60mA
   I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=00 Driver=usbhid
   E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms

but, when i run newhidups this is what i get:

   [/usr/local/nut-2.0.2](10)# ./bin/newhidups -DDDDD auto
   Network UPS Tools: New USB/HID UPS driver 0.23 (2.0.2)

   debug level is '5'
   Opening new device (03F0/1017)
   Opening new device (0409/0058)
   Opening new device (09AE/0001)
   Opening new device (0409/0058)
   Opening new device (0000/0000)
   Opening new device (0000/0000)
   Opening new device (0000/0000)
   found 0 (-1)
   No USB/HID UPS found

from looking at the newhidups source i know that this ups isn't supported 
yet, but it doesn't even print out the "manufacturer not supported" 
message even though the vendor id 09ae matches.

hopefully i haven't missed something obvious but i would really like to 
help get this ups working with nut if it's possible.



Bryan Olmstead

More information about the Nut-upsuser mailing list