[Nut-upsuser] Best Fortress LI660VA-Question(s)

Ralf Folkerts ralf.folkerts at gmx.de
Tue Aug 30 14:39:03 UTC 2005

Am Dienstag, den 30.08.2005, 09:11 -0400 schrieb Charles Lepple:

Hi Charles,

thank you for your fast reply!

> > However, no comms is possible with the UPS. I sent dozenz of "<cr>" and
> > also "Q"<cr> but without getting any Reply from the UPS.
> Did you turn off hardware and software flow control?
> Also, what baud rate did you try? 1200 is common for UPSes.

Yepp, I tried w/o Hardware (as the Flow-Control-Lines are not connected)
and both with and w/o Software Flow-Control. I used 1200/8/N/1, as
that's the Comm Speed when Setpoint 7 is set to 1.

> > However, when I
> > switch the UPS off I get <strange Character>{0001}. I first thought this
> > was by accident, but it's repeatable.
> Many serial devices will do this when you power them down. I'm not
> sure that this is an attempt at communication.
> > Now, does anyone here have a hint for the Comms? It seems my Cable is
> > not 100% OK -- but how must it look like?
> not sure about this, but you might want to use a multimeter to probe
> around and make sure that the pin connected to TX on the PC is
> somewhere near ground, and the pin connected to RX is at least 3V
> above or below ground (I always get mark and space polarity mixed up,
> but it should not be at ground).

OK; I gave that a try! They are at -10V (Pin 2) and -6V (Pin 3).

I just tried a bit further: It seems the Communication does work

I don't get a prompt; however, when I enter "password" or "password
2639" the UPS responds with a "?". Well, it repsonds with a Questionmark
to almost everything I enter :-( Until now I only found "def" to display
a long line of Data...

Seems I now have to check the "old" bestfortress Driver for possible
Commands and Resonses from the UPS (however, if someone who reads this
has some hints re. Commands and the UPS at all it would be great if you
could post it :-)).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20050830/ae190ff3/attachment.pgp

More information about the Nut-upsuser mailing list