[Nut-upsuser] ownership of pid directory

David Benfell benfell at speakeasy.net
Thu Dec 28 05:12:44 CET 2006

Hello all,

Some time ago, you all were very helpful in getting nut running on an OpenBSD
system, using--for what it's worth--a CyberPower 1500AVR.

So I finally got my FreeBSD system's UPS, also a CyberPower 1500AVR, within
reach of its serial cable and I'm trying to get nut running here.  I'm going

Basically, I copied the OpenBSD configuration over to the FreeBSD system and
tried to put everything in the right place.  It looked like the FreeBSD port
wants to run as user uucp rather than nutmon, so I changed ups.conf and
upsmon.conf accordingly and tried changing the ownership of everything to

upsdrvctl still complains that it "Can't chdir to /var/db/nut: Permission denied"
The directory exists and is owned by both user and group uucp.  What does it

David Benfell, LCP
benfell at parts-unknown.org
Resume available at http://www.parts-unknown.org/

More information about the Nut-upsuser mailing list