[Nut-upsuser] ownership of pid directory

Doug Reynolds mav at wastegate.net
Thu Dec 28 17:37:17 CET 2006

David Benfell wrote:
> Hello all,
> Some time ago, you all were very helpful in getting nut running on an OpenBSD
> system, using--for what it's worth--a CyberPower 1500AVR.
> So I finally got my FreeBSD system's UPS, also a CyberPower 1500AVR, within
> reach of its serial cable and I'm trying to get nut running here.  I'm going
> nuts.
> Basically, I copied the OpenBSD configuration over to the FreeBSD system and
> tried to put everything in the right place.  It looked like the FreeBSD port
> wants to run as user uucp rather than nutmon, so I changed ups.conf and
> upsmon.conf accordingly and tried changing the ownership of everything to
> uucp.
> upsdrvctl still complains that it "Can't chdir to /var/db/nut: Permission denied"
> The directory exists and is owned by both user and group uucp.  What does it
> want?
I not sure which driver you are using, but the generic driver is the 
only one that works _well_.

        driver = genericups
        port = /dev/cuad0
        upstype = 7
        desc = "Hive UPS"

The cpsups driver has some flow control issues...  my cyberpower 1200AVR 
is kinda dumb. 

More information about the Nut-upsuser mailing list