[Nut-upsuser] MegaTech UPSilon 2000 usage

Arnaud QUETTE Arnaud.QUETTE at mgeups.com
Tue May 9 09:06:15 UTC 2006

Hi Stefanos,

I've forwarded your mail to the nut user mailing list, which is the right 
place to get support.
thanks to subscribe to it (http://alioth.debian.org/mail/?group_id=30602).

Linux / Unix Expert - MGE UPS SYSTEMS - R&D Dpt
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://people.debian.org/~aquette/
OpenSource Developer - http://arnaud.quette.free.fr/

----- Réacheminé par Arnaud QUETTE/FR/EMEA le 05/09/06 11:02 AM -----

Stefanos Sofroniou <ssofroni at cytanet.com.cy> 
05/08/06 06:35 PM

arnaud.quette at mgeups.com

UPSilon 2000 usage

Dear Sir,

I have recently purchased a MegaTech UPS (UPSilon 2000) and the cd that 
came with it was including drivers for Operating Systems like Novell, all 
windows, Linux and FreeBSD. 
Unfortunatelt the drivers for Linux / FreeBSD are quite old (Linux 2.x and 
FreeBSD 2.x, 3.x, as also a patch for FreeBSD 4.x) and even though I tried 
to install them was a total waste of time for me. Nothing was applicable 
for it. Compat3x is no longer support.

I went to FreeBSD channel (IRC) and spoke with few folks and they 
recommended me NUT. I installed it successfully from ports but right now I 
am confused. I tried to read the instructions from NUT web page but 
unfortunately I confused my self more.
I have found the samples .conf files that installed with the ports and I 
created new .conf files so I may use them for my usage and I saw the 
examples mentioning UPS name...sparky was the example if I am not 
Well...what name shall I give for my UPS? The name of the model which is 
UPSilon 2000?
[UPSilon 2000] or [UPSilon]?
Another thing is with serial port devices. In the example you are giving a 
name for serial port ttyS1 or something similar (for Linux) and as you 
mentioned for FreeBSD we shall use cuaaN device. Well 

FreeBSD# ls
acd0             ctty              lpt0             stderr          ttyv6
acd0t01        cuad0 ???  lpt0.ctl         stdin           ttyv7
acpi              cuad0.init    mdctl           stdout         ttyv8
ad0               cuad0.lock   mem            sysmouse    ttyv9
ad0s1           cuad1???     net              ttyd0            ttyva
ad0s1a         cuad1.init    net1             ttyd0.init     ttyvb
ad0s1b         cuad1.lock   net2             ttyd0.lock   ttyvc
ad0s1c         devctl           net3             ttyd1           ttyvd
ad0s1d         devstat        network       ttyd1.init    ttyve
ad0s1e         dumpdev     nfs4              ttyd1.lock   ttyvf
ad0s1f          fd                 nfslock         ttyp0           urandom
agpgart        fd0              null               ttyp1           usb
apm              fido             pci                 ttyp2           usb0
ata                geom.ctl     ppi0              ttyv0            usb1
atkbd0          io                psm0             ttyv1           xpt0
bpf0              kbd0           ptyp0            ttyv2           zero
bpsm0           klog            ptyp1            ttyv3
console          kmem        ptyp2             ttyv4
consolectl      log             random         ttyv5

these are my devices and I have make bold the possible devices that I 
could use according your manual. The strange thing is that should be a 
sioN device somewhere here and there is not. Also the the paradox thing is 
that I have only one serial port! and here I can see 2 ttydNs. Also I red 
the handbook for serial printers installations and they use ttydN. What 
shall I do? You are mentioning to Installation procedure to use cuaaN...

Another thing: I really need your help because also the 
/usr/local/ups/bin/upsdrvctl start does not exist.

With dmesg command I can see 

fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on 
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>

What is going on here? :))))) I have only one serial port (COM 1 I guess). 
I need to know what device shall I use. Also my UPS is an "online" model 
because i have problem with my cables at home (we are renting it) and this 
problem manage to burn me three times my TFT power supply. Fortunately was 
into the warranty, I replaced my screen and my power problem solved with 
the usage of UPS because it has also stabilizer. I have to be very careful 
with the tests that I must try. So please help me with this only, not to 
tell me step by step what to do but to help me go on with one step 

Please help me whenever you can.

Thank you very much

Stefanos Sofroniou

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20060509/bfcfedb7/attachment-0001.html

More information about the Nut-upsuser mailing list