[Nut-upsuser] Sweex 1000VA UPS

YvesDM ydmlog at gmail.com
Sat Nov 11 10:52:30 CET 2006

> Ok, I 've done some more testing.
> I did comment out the upsmon entry in /etc/default/nut
> Then loaded the driver like:
> /lib/nut/genericups -x upstype=7 /dev/ttyS0
> It loaded and according syslog:
> Nov 11 10:19:47 radius1 genericups[8469]: Startup successful
> However when I tried:
> radius1:/etc/nut# upsc ups_name at localhost
> Error: Connection failure: Connection refused
> radius1:/etc/nut#
> I've done this for ttyS0 & ttyS1 (there are no more, 2 results in an error
> at fire up)
> I also changed the permissions on ttyS1 like
> radius1:/etc/nut# ls -al /dev/ttyS0
> crw-rw----  1 root nut 4, 64 2005-02-26 07:39 /dev/ttyS0
> radius1:/etc/nut#
> Same problem.
> The only things left here  are.
> 1. There is a problem with the serial cable. (I tried 2 of them)
> How will I know if the cable that came with the UPS is the right one?
> 2. That thing just won't ever work for linux.
> The new series of MGE are Ellipse ASR I hope someone can confirm these
> things work as they should
> with NUT running on debian stable.
> Many tnx
> Yves
Woops forget it!
I've noticed a typo in /etc/default/nut
# start upsd
START_UPSD=yed (instead of yes!)

Ok, now I got

radius1:/etc/default# upsc ups_name at localhost
driver.name: genericups
driver.parameter.port: /dev/ttyS0
driver.parameter.upstype: 7
driver.version: 2.0.1
driver.version.internal: 1.30
ups.mfr: CyberPower
ups.model: Power99
ups.status: OL

We move on...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20061111/f138153b/attachment.htm

More information about the Nut-upsuser mailing list