[Nut-upsuser] Sweex 1000VA UPS

YvesDM ydmlog at gmail.com
Sat Nov 11 10:48:03 CET 2006

On 11/10/06, Arjen de Korte <nut+users at de-korte.org> wrote:

> If you're willing to try a few more things, comment out the part in the
> NUT startup script where 'upsmon' is started/stopped and fire it up. With
> 'upsc myups at localhost' you should be able to see the status of the UPS,
> without the risk of shutting down your system when things are not
> configured properly. Try at least /dev/ttyS[0-3] with the UPS in different
> serial ports on your server. Remember to stop the script before modifying
> and starting it again. Good luck!
> Kind regards,
> Arjen
Ok, I 've done some more testing.
I did comment out the upsmon entry in /etc/default/nut
Then loaded the driver like:
/lib/nut/genericups -x upstype=7 /dev/ttyS0
It loaded and according syslog:
Nov 11 10:19:47 radius1 genericups[8469]: Startup successful
However when I tried:
radius1:/etc/nut# upsc ups_name at localhost
Error: Connection failure: Connection refused

I've done this for ttyS0 & ttyS1 (there are no more, 2 results in an error
at fire up)
I also changed the permissions on ttyS1 like
radius1:/etc/nut# ls -al /dev/ttyS0
crw-rw----  1 root nut 4, 64 2005-02-26 07:39 /dev/ttyS0

Same problem.
The only things left here  are.
1. There is a problem with the serial cable. (I tried 2 of them)
How will I know if the cable that came with the UPS is the right one?
2. That thing just won't ever work for linux.

The new series of MGE are Ellipse ASR I hope someone can confirm these
things work as they should
with NUT running on debian stable.

Many tnx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20061111/a8910d99/attachment-0001.html

More information about the Nut-upsuser mailing list