[Nut-upsuser] Strange battery power shortage on an Unitek iZi UPS 525

Ciprian Marius Vizitiu cvizitiu at gbif.org
Sat Dec 22 14:34:54 UTC 2007

Hi everyone,

I've been using nut 2.0.3 for more than a year on a Unitek iZi UPS 525
(which is a rebadged Mustek). Everything worked fine and last week, when
pressed by RENEL :-) I ran a battery test which showed the system to have
17min of back-up power (yes, still haven't figured out how to use

The system used for testing was an old PIII/500MHz/512KB cache, 256MB RAM (3
x SDRAM 100MHz) 1 x 8GB hdd IDE and a 250W PS. For various reasons I've
switched to a new system consisting of one Duron 900MHz, 1 piece of 512MB
RAM DDR1 and a 12GB IDE (same family as the previous 8GB). After reinstall,
an upgrade to "nut-2.2.0-6.1.fc8", copying of the same nut config files and
editing them so that the driver is now megatec instead of powermust I've
discovered that the battery time is down to a mere 4 minutes. Any ideas are
welcome, so far I can only think of:

1. The battery has lost its power in less than a week since my last test

2. Duron 900/64KB cache chews three times more power compared to the old
PIII/500. I strongly doubt this one but I'm willing to hear other

3. Somehow the newer version of nut fails to correctly read/interpret the
values from the UPS and decides to shut down earlier.

4. ... any other ideas?

Oh, since I no longer have the external DB9 connector for this motherboard
I've resorted to a USB2Serial from "Sandberg". Apparently nut doesn't seem
to care if the port is ttyS0 or ttyUSB0...

PS. I've also replaced the case; can this be the reason? :-]

More information about the Nut-upsuser mailing list