[Nut-upsuser] ST7 RS232 USB Bridge (STMicroelectronics) UPS

Dâniel Fraga fragabr at gmail.com
Sun Jul 1 17:34:56 UTC 2007

On Sun, 1 Jul 2007 11:16:12 -0400
"Charles Lepple" <clepple at gmail.com> wrote:

> On 7/1/07, Dâniel Fraga <fragabr at gmail.com> wrote:
> >         I tried newhidups, hidups also without success...
> You could try running 'newhidups -u root -x vendorid=0483 -x explore
> -DD' on the UPS, and send the output to the list. (If it's long,
> please gzip the output and attach it.) This is a debugging mode, so it
> will not actually monitor the UPS state, but the information can help
> us match the device to others that are supported by the new
> megatec_usb driver.

Checking device (0483/0035) (001/003)
- VendorID: 0483
- ProductID: 0035
- Manufacturer: unknown
- Product: unknown
- Serial Number: unknown
- Bus: 001
Trying to match device
Device matches
HID descriptor too short (expected 8, got 0)
HID descriptor retrieved (Reportlen = 29)
Unable to get Report descriptor (-110): Connection timed out
> It may also be worthwhile to try the megatec_usb driver directly. This
> driver was introduced after 2.0.5 was released. The latest NUT release
> candidate is 2.2.0-pre2, and it can be downloaded here:
> http://www.networkupstools.org/source.html
> Let us know how it works.

	I tried the megatec_usb, but it failed:

Network UPS Tools 2.2.0-pre2- - Megatec protocol driver 1.5.4 [megatec_usb]
Carlos Rodrigues (c) 2003-2007

Serial-over-USB transport layer for Megatec protocol driver [megatec_usb]

No supported devices found. Please check your device availability with 'lsusb'
and make sure you have an up-to-date version of NUT. If this does not help,
try running the driver with at least 'vendorid' and 'subdriver' options
specified. Please refer to the man page for details about these options
(man 8 megatec_usb).
Please report your results to the NUT user's mailing list
<nut-upsuser at lists.alioth.debian.org>.

	Then I tried to use agiler and krauler sobdrivers without
success. I used vendorid and productid and nothing helped.

	What else can I try? Thank you!	 


More information about the Nut-upsuser mailing list