[Nut-upsuser] APCsmart serial port problem

Patrick Nolan Patrick.Nolan at stanford.edu
Tue Jun 5 22:29:01 UTC 2007

Arjen de Korte wrote:

> This looks more like a hardware/interrupt problem to me. Do you have the
> chance to test this on a different port (or even machine) and checkout the
> results?
> You also wrote you had problems with this UPS and the software APC
> provided. Can you elaborate on that? Did this UPS ever work correctly?
I'm working in parallel with the APC tech support.  I never have been
able to get it to work properly.  There seems to be a certain random
component to the results.  I have obtained partial successes, as I have
mentioned here, but then I can't reproduce the results.

At one point I think I had the APC software running in simple signaling
mode.  Then I got ambitious and tried for smart signaling.  When the
stars are aligned favorably I can get their console application to
talk to the agent daemon.  But it always tells me that line power has
been lost, it's running on batteries, and the battery time limit has
been exceeded.  Meanwhile the lights on the UPS tell me that it's
happily running on line power.  Also they specify stty settings for
the serial port, and they won't stay put between runs.

I am currently quibbling with APC about whether they ship a GUI
installer in the Linux RPM; I don't see it; they say it's there, but
they haven't told me where to look.

Meanwhile I found a whole bunch of SELinux messages.  Some of them
clearly related to other parts of the system, but others might be
related to the serial port.  I turned SELinux down to Permissive, but
I don't see that it had any effect.

Also I've been learning about udev, so the owner and permissions of
the serial port can be kept under control.  So far that hasn't worked
either.  I created a file /etc/udev/rules.d/10-local.rules containing
the line
KERNEL=="ttyS0",  NAME="%k", OWNER="nut", GROUP="nut" , MODE="0660"
but it seems to have no effect.  The device file comes up belonging
to root:root.  I can change it by hand, but it switches back each time
I run apcsmart.  Clearly I'm doing something wrong there.

Oh yes, I wiggled the cable and screwed it on snugly at both ends.

More information about the Nut-upsuser mailing list