[Nut-upsuser] trouble with Cyber Power System CPS RS232 USB BRIDGE for UPS

Jon Bendtsen jon.bendtsen at laerdal.dk
Thu Nov 22 14:15:05 UTC 2007

On 22/11/2007, at 14.55, Arjen de Korte wrote:

>> Recently i bought a MicroDoWell BP50, and with it followed a USB 2
>> serial converter. When i plug it into my 2.6.19 kernel, dmesg shows
>> hiddev96: USB HID v1.10 Device [Cyber Power System CPS RS232 USB
>> BRIDGE for UPS] on usb-0000:00:04.2-2
>> usbcore: registered new interface driver usbhid
>> drivers/usb/input/hid-core.c: v2.6:USB HID core driver
> That's a little confusing. Apparently, Cyber Power System designed  
> this
> device to be used particularly for UPS use. However, all it should  
> do is
> provide a serial port, so that you can connect the 'powerpanel' or
> 'cpsups' driver to it.

i was thinking it new how to convert a serial port to a USB hid UPS  

>> So, i figured i should use usbhid-ups, /etc/nut/ups.conf
>> [switch]
>>   driver = usbhid-ups
>>   port = auto
> I understand what made you think this is the correct driver, but
> unfortunately it isn't. Worse still, CPS also uses this same VID:PID  
> for
> their USB HID UPS'es, so we have really no means to exclude this in  
> the
> 'apc-hid' subdriver.
>> The MicroDoWell BP50 only has a serial out, but i am using the serial
>> cable that came with the UPS. Unfortunately it is not very long, so
>> having a USB extender cable i connected the serial cable to the UPS  
>> and
>> the USB2serial converter and then the extender cable and into my  
>> server.
> Your serial-to-USB converter should provide a virtual COM port,  
> something
> like /dev/ttyUSB0 ot something like that. This port should be  
> configured
> in 'ups.conf' with either the 'powerpanel' or 'cpsups' driver. If no
> virtual COM port is created upon plugging in the serial-to-USB  
> converter,
> it is most likely not recognized by your kernel. In that case, the  
> only
> thing we can do for the moment is to suggest to try a different one  
> that
> is supported by your kernel.

I tried that part, but i can not get it to work. I tried ttyUSB0, 1, 2  
and 3. neither worked.

i will try to find another usb2serial converter


More information about the Nut-upsuser mailing list