[Nut-upsuser] Nut problems with Centos and Belkin UPS

Richard Chapman rchapman at aardvark.com.au
Mon Nov 26 02:03:13 UTC 2007

Thanks Arjen

I have changed the driver in my  ups.conf to usbhid-ups, and based on 
other literature I have read - I set the port to "auto", but at startup 
i get the error:

Starting UPS driver controller: Network UPS Tools: 0.28 USB communication driver 0.28 - core 0.30 (2.2.0-)

No matching HID UPS found
Driver failed to start (exit status=1)

I also tried setting the port to "/dev/hiddev0" and "/sys/class/usb/hiddev0"
 based on a gnome device manager view - but these gave the same error.
I have checked lsusb -vv - and it still reports the device as present, though at a different "device" number.
The change in number seems strange since I don't believe I have moved the cable nor rebooted the system.

Should the "auto" port specification work OK, and if so - can you 
suggest why it isn't being found. Alternatively - can you advise me how 
to find and specify the correct usb port.

You may be able to answer another question:
The "man belkinunv"  discusses a limitation of the belkin UNV ups not 
properly supporting soft shut-down - and also discusses a rather 
unsatisfactory (IMHO) workaround. I imagine this limitation will apply 
equally to the USB driver - though the workaround probably will not. I 
don't think this issue would force me to revert to the serial driver 
because i don't much like the strategy of completely flattening the 
battery to achieve a pseudo soft shut-down. Can you (or others) confirm 
that the limitation will also apply to the USB driver, and/or that the 
workaround will not be available in the USB driver?

Also - I am not familiar with the "version from the trunk" but I assume 
it is some "beta" development stream. If you think I would be well 
advised to look into this further - I would take your advise of course. 
Any tips of how to find this would be appreciated. So far - I have only 
worked from rpm distributions. If "the trunk" involves recompiling 
source3s - this may be a reasonable learning curve for me...:-)

Thanks again Arjen.

I really do appreciate your assistance.


Arjen de Korte wrote:
>> On the bottom of the Belkin UPS unit - is the model number: F6C120auUNV
>> The "au" is for Australia I think.
> It probably is. We've seen other combinations here, like 'eu', 'uk' and so
> on.
>> "man belkinunv" states that F6C120-UNV is supported - and I assumed that
>> the "au" would not prevent this.
>> I plugged in the USB to gather the information you requested. My
>> intention was to use the serial connection and probably still is, though
>> if there is a solution via USB - I would certainly consider it.
> There is and in many cases, it will be better than the serial connection.
> Many UPS'es use a fairly verbose protocol, where a faster (USB) interface
> helps to prevent timeouts.
>> I tried "lsusb -W" (as suggested) but this seems an invalid option so I
>> assume you mean "lsusb -v"
> No, I wrote 'lsusb -vv' (double 'v'). Apparently, this looks very similar
> in the font you're using... :-)
>> Below is the relevant part of the output from "lsusb -v".
> [...]
>> Bus 004 Device 002: ID 050d:0912 Belkin Components
> Good. This device is fully supported through the 'usbhid-ups' driver.
> Although the stable nut-2.2.0 version works with this UPS, you may want to
> try out the (improved) version from the trunk. If you don't know what the
> latter is, just wait for the upcoming stable release, which should be
> available shortly (Arnaud?)
> Best regards, Arjen

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20071126/6bdca966/attachment.htm 

More information about the Nut-upsuser mailing list