[Nut-upsuser] BelkinUNV Serial Problems (Was CyberPower 1500AVRT won't load driver!)

Richard Chapman rchapman at aardvark.com.au
Wed Nov 28 08:30:05 UTC 2007

Hi Charles - and thanks for your help.

Firstly just to fill you in - I have tried both Serial and USB 
connections. I have the USB connection "sort of" working - but only when 
I manually set permissions - which need to be manually re-set 
occasionally. This is not very satisfactory - and Tomas Smetana is 
looking into a possible packaging problem related to udev files (from 
what I understand).

As far as I can see - my problems with the serial port are not 
"permissions related" - so I assume there must be an unrelated problem. 
It sounds similar to the CyberPower problem from this original thread.

I have tried your suggestions:

> Try running the driver directly with "-DDD" on the command line, and
> copy-and-paste the error messages. (Also, please change the subject to
> match your driver.
[root at C5 /]# belkinunv -u root -DDDDDDDD -a BelkinSer
Network UPS Tools - Belkin 'Universal UPS' driver 0.06 (2.2.0-)

debug level is '8'
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS
No response from UPS

[1]+  Stopped                 belkinunv -u root -DDDDDDDD -a BelkinSer
[root at C5 /]#

This error goes on indefinitely. Then debug level doesn't seem to help 
>> I have checked
>> the permissions on ttyS0 and they appear correct. I find this a bit
>> puzzling - because I can't figure out how these permissions got set. How
>> did it know that I wanted to use ttyS0, apparently before I ever told it
>> what port to use?
> A little more detail would help here. In some cases, the permissions
> are what your distribution would normally use for the serial ports
> (e.g. group "uucp").
> What does "ls -l /dev/ttyS[01]" show?
[root at C5 /]# ls -l /dev/ttyS0
crw-rw---- 1 root uucp 4, 64 Nov 28 17:05 /dev/ttyS0

I think you are right. I guess the group "uucp" must be the default for 
this distribution (centos 5). That would explain the mystery.

>> I also have only one physical serial port on the box - though the device
>> manager reports 2 16550 ports. I can't really find a way to definitively
>> prove that the port on the back is ttyS0 - so any ideas how to do this
>> would be appreciated. Are there any settings that can be set for ttyS0,
>> such as baud rates etc, and if so - how is this done? I am relatively
>> new to Linux - so pleas be gentle with me...:-)
> I am fairly certain that each individual driver sets the baud rate if
> necessary - although some drivers have options to pick one of several
> baud rate options if the hardware supports multiple rates.
I also checked the belkinunv -h options - and there didn't seem to be 
anything related to baud rate setting etc. I guess the driver must just 
know the right baud rate.
> Often you will see a change in the output of "statserial /dev/ttyS0"
> after you plug a device into that port. (No guarantees, since some
> UPSes use simple signalling that does not show a difference in the
> status until the power fails, or the battery goes low.)
This sounds like a really useful hint - but "statserial" wont work for 
me. (command not found). Also "find -name statserial -print" from / 
couldn't find it - so I don't think it is on my system. Do I need to 
install another package? Or can I download it as a standalone tool? A 
quick google search indicated it was a standard linux tool - but for 
some reason - I don't seem to have it.

Thanks again Charles.


More information about the Nut-upsuser mailing list