[Nut-upsuser] Mustek drivers

Kjell Claesson kjell.claesson at epost.tidanet.se
Thu Dec 18 21:29:18 UTC 2008

Den Thursday 18 December 2008 17.05.59 skrev du:
> Hi Kjell,

Hi Mohanjith,

> The UPS is from one of the local manufacturers IE Tec. They no longer
> produce this UPS. I tried all drivers with no luck, namely apcsmart,
> belkin, belkinunv, bestuferrups, bestups, cpsups, cyberpower,
> energizerups, etapro, everups, genericups, isbmex, liebert,
> masterguard, mge‐shut, mge‐utalk, oneac,  powercom,  safenet,
> snmp-ups,  tripplite, tripplitesu, victronups.
If you look in the  nut source docs/megatec.txt you find.

The following drivers are targeted for "assimilation":

  * blazer (1)
  * fentonups (1)
  * mustek (1)
  * esupssmart (1)
  * ippon (1)
  * sms (1)
  * masterguard (3)

(1) megatec already supercedes this driver in functionality.
(2) megatec partially supercedes this driver in functionality, but some
    small features are missing (non-critical for normal operation).
(3) megatec partially supercedes this driver in functionality, but some
    important features are missing, which means some hardware may not be


So the driver should support the mustek protocol.

> With genericups I tried all UPS types with no luck. I have hit a brick
> wall.
The generic is only for contact closure and if the ups support this you may
have to use a differnet cable for this.

> Any ideas? Any help is appreciated.

Looking at your second mail you run the upsdrvctl with debug. This would not 
run the driver with debug.
You need to run it like.
/path/to/driver/megatec -DD -a patriot

You have to kill this with ctrl-c but you get debug info from the driver.

Check the manual for megatec, there is some flags you may alter, like DTR and 
RTS in the ups.conf. Also the sendpace can be altered, this is the wait 
between characters. (default 100mS) 

Run the driver in debug mode. Alter the DTR RTS value in the config and run it 
again. Se if you have any responce from the Q1 command. If you get response
alter the sendpace for relyable respons.

As it is a text protocol you may try minicom or any terminal program and send 
Q1/r (Q1 followed by return) and check if you get any responce.
ref: http://eu1.networkupstools.org/protocols/megatec.html


More information about the Nut-upsuser mailing list