[Nut-upsuser] Nut and PowerWare 5115

Kjell Claesson kjell.claesson at epost.tidanet.se
Tue Apr 21 15:39:37 UTC 2009

tisdag 21 april 2009 14:43:28 skrev  Greg:
> Hi Kjell,
Hi Greg,

> Sorry for the late reply been doing a lot of testing.
No problem.

> I got the package from
> http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/nut_2.4.
>1-1_arm.ipk It pretty much pre-compiled which are then extracted to the
> device on installation.

> I tested nut and the 5115 under Ubuntu 8.10. Ubuntu comes with nut 2.2.2 by
> default which works fine. I installed 2.4.1 which does not work either.
This is not so good. Then we may have a bug introduced to the nut_usb.
I cc this mail to Arnaud.
Arnaud can you run some tests on the PW5115 with NUT 2.4.1 ?
We may have broken something from version 2.2.2.

But it may be the package also but I think Arnaud is working on that to.

The error:
> USB error: could not set config 1: Device or resource busy
> Can't set POWERWARE USB configuration
> Unable to find POWERWARE UPS device on USB bus
Is indicating that something is already running.
Did you check that the debug run was the only thing running at the moment.

> So I compiled and installed 2.2.2 on my QNAP device and it still doesn't
> work.
> 2.2.2 was compiled on my QNAP without HAL support just USB support.
Yes, and I see that you get the same error as you get on 2.4.1 on the QNAP.

The problem is that I don't have any 5115 to test this on. So I hope that 
Arnaud can test this. My PW3105 is running fine on usb on 2.4.1.


More information about the Nut-upsuser mailing list