[Nut-upsuser] Nut and PowerWare 5115

Greg greg_roll at hotmail.com
Thu Apr 23 08:56:55 UTC 2009

Hi Arnaud and Kjell,

Please find answers below.

I also re-compiled 2.4.1 myself on Ubuntu and still got the same issues/errors.

If you have anything you would like run or if there is any other debugging I am happy to compile/run it.

Is there anything else you can think of that I can try to get nut 2.2.2 working on my QNAP??

From: Arnaud Quette 
Sent: Wednesday, April 22, 2009 9:31 PM
To: Greg ; Kjell Claesson 
Cc: nut-upsuser at lists.alioth.debian.org 
Subject: Re: [Nut-upsuser] Nut and PowerWare 5115


I forgot to add that I'm interested in an upsc output of the working version (ubuntu 8.10 with 2.2.2...)

Here you go

root at ubuntuvmp:~# upsc PowerWare at localhost
ambient.temperature: 42
battery.charge: 100
battery.runtime: 2334
battery.voltage: 13.47
driver.name: bcmxcp_usb
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.version: 2.2.2
driver.version.internal: 0.14
input.frequency: 50.34
input.voltage: 249
output.current:  0.0
output.frequency: 50.34
output.phases: 1
output.voltage: 249
output.voltage.nominal: 240
ups.firmware: Cont:01.00 Inve:10.04
ups.load:  10.2
ups.model: 51150500A           500VA
ups.power.nominal: 500
ups.serial: UY196A0229
ups.status: OL


thanks (and sorry for top posting)

2009/4/22 Arnaud Quette <aquette.dev at gmail.com>

  Greg, Kjell,

  2009/4/21 Kjell Claesson <kjell.claesson at epost.tidanet.se> 

    tisdag 21 april 2009 14:43:28 skrev  Greg:
    > Hi Kjell,
    Hi Greg,

    > Sorry for the late reply been doing a lot of testing.

    No problem.

    > I got the package from
    > http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/nut_2.4.
    >1-1_arm.ipk It pretty much pre-compiled which are then extracted to the
    > device on installation.


    > I tested nut and the 5115 under Ubuntu 8.10. Ubuntu comes with nut 2.2.2 by
    > default which works fine. I installed 2.4.1 which does not work either.

    This is not so good. Then we may have a bug introduced to the nut_usb.
    I cc this mail to Arnaud.
    Arnaud can you run some tests on the PW5115 with NUT 2.4.1 ?
    We may have broken something from version 2.2.2.

    But it may be the package also but I think Arnaud is working on that to.

  well, the packages (and ipk are iirc kinda simplified debs) are quite straighforward.
  the "nut" package (for example on Ubuntu) includes the core and the serial/usb drivers, with the udev file and so on. the hal support is in another packages that is conflicting with the "nut" one (in order to avoid runtime conflict between the classic and hal drivers).

    The error:

    > USB error: could not set config 1: Device or resource busy
    > Can't set POWERWARE USB configuration
    > Unable to find POWERWARE UPS device on USB bus

    Is indicating that something is already running.
    Did you check that the debug run was the only thing running at the moment.

  yup, 2nded.
  Greg: can you try again this test please.

  Yes it was the only thing running. I even restarted a few times and tried a few more times.

    > So I compiled and installed 2.2.2 on my QNAP device and it still doesn't
    > work.
    > 2.2.2 was compiled on my QNAP without HAL support just USB support.

    Yes, and I see that you get the same error as you get on 2.4.1 on the QNAP.

    The problem is that I don't have any 5115 to test this on. So I hope that
    Arnaud can test this. My PW3105 is running fine on usb on 2.4.1.

  I've just made some test on PW5115 500i (500VA), nut 2.4.1(-2 ; packaged) on an Ubuntu 8.10. Everything was fine. same goes for 2.2.2 (from source this time)
  the firmwares are:
  - USB: 01.00
  - Main:10.04

  This is the only 5115 I have underhand, but what is puzzling me is the exact model name:
  - mine (with 2.2.2) displays "Model = PW5115 500i         500VA"
  - while Greg's displays        "Model = 51150500A           500VA"

  a subtle difference! though the 2 firmwares (USB and main) are identical.
  iirc, this value (the name) can be changed. Have you done so Greg?

  I was unaware about changing the name of the UPS. I have not done this.

  I'm still learning PW, and will have to check with the PW people there.
  more info soon

  Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
  Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
  Debian Developer - http://www.debian.org
  Free Software Developer - http://arnaud.quette.free.fr/ 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20090423/63a9aafa/attachment.htm>

More information about the Nut-upsuser mailing list