[Nut-upsuser] My previous post (lengthy, lots of tarace output)

Gene Heskett gene.heskett at gmail.com
Thu Dec 31 14:24:45 UTC 2009

On Thursday 31 December 2009, Arjen de Korte wrote:
>Citeren Gene Heskett <gene.heskett at gmail.com>:
>> There is also a missing /etc/sysconfig/ups file, which I have NDI what to
>> put into, so that bit of code in the init.d/ups is commented out, and
>> SERVER=master is set in it.
>NUT doesn't use a /etc/sysconfig/ups file (this is probably added by
> Fedora).
And I don't know that the file ever existed on my system, ever.  So that part 
of the init script has been disabled.

>Do yourself a favor and ask for help on a Fedora mailing list and
>preferably find some pre-compiled RPM's to install on your system. I
>don't have the time, nor the energy to talk you trough all stages of
>building NUT for Fedora (or any other distro, for that matter).
>Building from sources is clearly not something for you (no pun

Building from srcs is not a problem, but one does have an expectation of 
reasonable defaults.  Only an amanda build, which I may do several times a 
week, requires a longer ./configure line than I used to build the last 
version of 2.4.1.  That, long since, 10 years ago for the 1st version, has 
been carved into a build script, so my fumble fingers don't have to get it 
right every time.  This I think, should also be made into a script so that if 
I can get it working, the next release should too.

FWIW Arjen, I routinely build my own kernels, and just as routinely build 
each development snapshot of amanda, the backup program.  And I have been 
carving code, often in assembly, or in my first 2 projects in the late 1970's 
in hexidecimal, entering it into memory with a hex monitor.  Currently 
running kernel 2.6.32, and have tried but found its usb support 
broken, and have tried 2.6.33-rc2, which was a disaster, dying in less than 
an hour with lots of stuff not working from the gitgo.

You requested logs, which I sent, and which were not commented on in any 
reply I received.  Those logs show the usbhid-ups/belkin driver combination 
losing comm with the ups and having to redo its search for the ups several 
times a minute, but you apparently sent them to /dev/null.  Were I the coder 
for that piece of code, that would have raised all sorts of red flags.

This loss of comm is the reason I cannot run upsmon as its setup now, but 
usbhid-ups is showing in an htop display, running as the user ups.  So is 
upsd, also running as the user ups.  Not by the init script, I still need to 
fine tune that.  but if I start upsmon, then the kde write daemon floods my 
screens with "comm lost", "can't comm", and "comm restored" messages, which 
also spam the logs.

The instructions in the example files are even occasionally miss-leading, and 
I just found from an error message, that the allowfrom has been deprecated 
but not removed from one of the .conf files.

I believe, if the comm problems can be sorted, that I may have a working 
setup & all I have to do is fine tune the /etc/init.d script to re-establish 
what is running right now.

So the end is in sight, and its a poor time to bail out now..

>I'm sorry, but the best advice I can give you here is to
>find an RPM where this is already done for you.

Which I have explained is not available for F10.

I'm thinking of moving to a mandriva 2010x64 install, but I don't recall 
seeing nut available in rpmdrake.

>Best regards, Arjen

Thanks Arjen.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)

Griffin's Thought:
	When you starve with a tiger, the tiger starves last.

More information about the Nut-upsuser mailing list