[Nut-upsuser] Problems with Unitek Alpha 1000 Ps

Jordi Moreno jmoreno at cim.es
Mon Jan 26 10:55:42 UTC 2009

Arjen de Korte escribió:
> Citeren Jordi Moreno <jmoreno at cim.es>:
>> Asking for UPS status [Q1]...
>> get_data_agiler: raw dump: (0 bytes) =>
>> get_data_agiler: raw dump: (8 bytes) => 30 30 31 30 30 30 0d 00
>> Q1 => FAILED [short read]
>> Q1 detail: (6 bytes) => 30 30 31 30 30 30
> [...]
>> Megatec protocol UPS not detected.
> This UPS isn't speaking the Megatec protocol. It doesn't look like 
> anything familiar to me either.
>> Trying with usbhid-ups:
> It most certainly isn't a HID Power Device Class UPS, looking at the 
> length of the report descriptor, so this won't work either.
> [...]
>> So, can I try a different driver? Could be this UPS supported by NUT? I
>> can give strace information too, but I don't want to make my mail
>> longer!
> Strace is a waste of effort here. We're not debugging a timing problem 
> here, we just don't what protocol the UPS uses. If you have (bundled) 
> software available for Windows, you might use usbsnoop to try and see if 
> you can find out how to communicate with this device. Until then, there 
> is nothing we can do for you.
>> Sorry, but I'm a bit desperate... I have searched the web and
>> didn't found any information about this UPS.
> You could also reverse this. If you really need your UPS to be supported 
> in NUT, buy something that is listed as 'supported' instead. If you're 
> looking to quickly resolve this, this might be the best advice we can 
> give you. Currently, you're lacking both the protocol information and a 
> driver to use it. Getting this supported may take a while.
> Best regards, Arjen


I've tried usbsnoop on a Windows machine, connected to the UPS. Software 
bundled with the UPS is WinPower, and it seems to work fine. The problem 
is that I don't know what to look for at the usbsnoop log, since there's 
too much information on it (running for five minutes, more or less, 
generated a 1MB log file!). I'm not a device driver developer but I 
would gladly help in anything I can.

There's a version of WinPower for *nix, but unfortunately it won't work 
with an USB connection. Is there any way I can make the USB connection 
work as a serial one? Since the device detected is an USB-RS232 
interface, I think it cold be an option... I've tried with usbserial 
with no success. If I could achieve this, WinPower would do the work 
while I investigate more... If not, I will need to buy another UPS...

Thank you very much for your help.

More information about the Nut-upsuser mailing list