[Nut-upsuser] Usbhip-ups going wild

Antoine Gatineau antoine.gatineau at alcatel-lucent.com
Fri Jul 31 13:03:16 UTC 2009

Indeed, nut depends on some packages not the distribution itself.
You are surely right. 

Anyway, here are the links :
RHEL 4 : ftp://rpmfind.net/linux/EPEL/4ES/SRPMS/nut-2.2.0-4.el4.src.rpm
RHEL 5 : nut-2.4.1 found only on this one

On rpmfind.net, nut-2.4.1 is on available for recent fedora, doesn't work
with RHEL4 or 5...

FYI, in RHEL 4, I have a dependency issue when compiling nut-2.4.1 :
./configure --with-name=ups --with-group=nut --with-usb --with-hal

(hal-devel is installed)
Configure: error: "libhal not found, required for HAL support"
But libhal is located in /usr/lib (.so and .a)

I just tried it out. That is why I concluded nut-2.4.1 was not compliant
with RHEL 4.


-----Message d'origine-----
De : Charles Lepple [mailto:clepple at gmail.com] 
Envoyé : vendredi 31 juillet 2009 13:53
À : Antoine Gatineau
Cc : nut-upsuser
Objet : Re: [Nut-upsuser] Usbhip-ups going wild

On Fri, Jul 31, 2009 at 4:04 AM, Antoine
Gatineau<antoine.gatineau at alcatel-lucent.com> wrote:

> Well I have tried to upgrade the nut drivers but it can't compile on 
> RHEL4 due to dependencies.
> Newer nut require RHEL5. Am I right?

Nothing in NUT itself depends on RHEL5, but the RPM spec file might be
written to require versions of packages only in RHEL5.

Do you have URLs for the SRPMs for RHEL4 and 5? We might be able to help

- Charles Lepple

More information about the Nut-upsuser mailing list