[Nut-upsuser] NUT upsstats.cgi problem

Brother Railgun of Reason alaric at caerllewys.net
Fri Jun 5 13:17:38 UTC 2009

On Thu, Jun 04, 2009 at 10:00:50PM -0400, Charles Lepple wrote:
> On Thu, Jun 4, 2009 at 9:21 AM, Brother Railgun of Reason
> <alaric at caerllewys.net> wrote:
> > MONITOR tokamak at localhost "HP R3000 XR (Server rack)"
> >
> > upsc does indeed work.  upsstats.cgi doesn't.  upsstats.cgi(8) isn't
> > really useful either.
> Odd - upsc uses the same library as upsstats.cgi, so I would expect
> the same error from both.
> What happens if you run upsstats.cgi from the command line?

The same thing.  (I hadn't tried that previously, but just did.)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<title>HP R3000 XR (Server rack) : [error: Invalid argument]
 on tokamak at localhost</title>
<!-- LINK REL="stylesheet" TYPE="text/css" 
HREF="http://localhost/nut/nut.css" / -->
<body BGCOLOR="#808080" TEXT="#00FC00" LINK="#0000EE" VLINK="#551A8B">


<th COLSPAN="20">Network UPS Tools upsstats 2.4.1 - HP R3000 XR (Server 
rack) - [error: Invalid argument]
 on tokamak at localhost</th>

<th>Fri Jun 05 09:15:34 EDT 2009</th>


<td BGCOLOR="#000000" VALIGN="TOP">

<table BORDER="0">      <!-- table 2 -->

<th ALIGN="RIGHT">UPS Model:</th>
<td>[error: Invalid argument]


  Phil Stracchino, CDK#2     DoD#299792458     ICBM: 43.5607, -71.355
  alaric at caerllewys.net   alaric at metrocast.net   phil at co.ordinate.org
         Renaissance Man, Unix ronin, Perl hacker, Free Stater
                 It's not the years, it's the mileage.

More information about the Nut-upsuser mailing list