[Nut-upsuser] Powerware USB issue solved (bcmxcp_usb)

Kjell Claesson kjell.claesson at epost.tidanet.se
Sat Oct 10 08:41:19 UTC 2009

Hi Greg,
> Hi Arnaud,
> I must be doing something wrong.
> I pulled down revision 2015 and even browsed through
>  http://svn.debian.org/wsvn/nut/trunk/?rev=0&sc=0 and drivers/bcmxcp.c
>  shows driver version 0.22.
Yep, think that Arnaud missed to change the number.
But he should change the usb subdriver number to 0.18 instead.

The main numbering 0.22 is for the protocol part, that is the same for 
usb and serial.

The changes was made to a included function file nut-usb, that have no 
revision number. But it is only the usb part of bcmxcp that use this file.

> I can't seem to pull down a file with version 0.23.
> In my last post I ran from /usr/local/ups/bin/bcmxcp_usb but I had copied
>  the compiled file there.
> Could you possibly explain what im doing wrong or even send me a tar file
>  of the source?
You can run the driver in debug mode directly from the build. So when you have
compiled you can call /path/to/nut/drivers/bcmxcp_usb -DD -a<ups>.
The you don't have to move it for testing.

What is the outcome of the debug run ?
Same problems?


More information about the Nut-upsuser mailing list