[Nut-upsuser] Powerware USB issue solved (bcmxcp_usb)

Greg greg_roll at hotmail.com
Sat Oct 10 06:58:16 UTC 2009

Hi Arnaud,

I must be doing something wrong.

I pulled down revision 2015 and even browsed through http://svn.debian.org/wsvn/nut/trunk/?rev=0&sc=0 and drivers/bcmxcp.c shows driver version 0.22.

I can't seem to pull down a file with version 0.23.

In my last post I ran from /usr/local/ups/bin/bcmxcp_usb but I had copied the compiled file there.

Could you possibly explain what im doing wrong or even send me a tar file of the source?


From: Arnaud Quette 
Sent: Saturday, October 10, 2009 7:39 AM
To: Greg 
Cc: Greg Vickers ; Thomas Zulliger ; NUT Users 
Subject: Re: [Nut-upsuser] Powerware USB issue solved (bcmxcp_usb)

Hi Greg

2009/10/7 Greg  
  Thanks for continuing to look at this. Much appreciated!

part of Eaton dedication to NUT users ;-)

  I compiled the driver on my QNAP as I didn't have time to muck around with Ubuntu.

  Here is my output
  [/] # /usr/local/ups/bin/bcmxcp_usb -DDDD -a qnapups -u admin
  Network UPS Tools - BCMXCP UPS driver 0.22 (2.4.1)
  USB communication subdriver 0.17

this is still the old driver! the new version is 0.23...

as told in my mail, you can run it from the build directory using:
$ ./drivers/bcmxcp_usb -DD -a <ups name>

otherwise, do a make install before calling the driver.

Linux / Unix Expert R&D - Eaton - http://www.eaton.com/mgeops
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/

__________ Information from ESET Smart Security, version of virus signature database 4494 (20091009) __________

The message was checked by ESET Smart Security.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/nut-upsuser/attachments/20091010/026b891d/attachment.htm>

More information about the Nut-upsuser mailing list