[Nut-upsuser] Eaton / MGE Ellipse MAX 600 USBS and nut

Michel Bouissou michel-nut at bouissou.net
Fri Jan 22 10:19:33 UTC 2010

Hi there,

I've replaced yesterday my old UPS with a brand new "Eaton Ellipse MAX 600 

I've choosed the Eaton (previously MGE) both because I've always been 
extremely satisfied with MGE UPSes of all kinds at work, and because of the 
involvement of MGE (with Arnaud) in nut development, which made me quite sure 
that I would have no trouble with an Eaton (MGE) UPS and nut, where my 
previous old UPS was working OK with old nut versions, but not anymore with 
recent nut versions.

So OK, I went to the Ellipse MAX 600, and have a couple questions / remarks :

- This UPS supporting both serial (mge-shut) or USB (usbhid-ups) 
connections/drivers, is there a choice that is "better" than the other in 
Linux ? Do both drivers / connection methods give access to the exact same 
parameters / information on the UPS ?

- So far I've choosen "serial" for I assume the serial connection to be 
simpler and more reliable (?) (doesn't need any access to libusb, doesn't need 
any filesystem mounted to communicate with UPS...)

Well, once done, this works (see http://www.bouissou.net/ups ) but I'm puzzled 
to see that my new UPS seems unable to display input voltage and that it 
always displays output voltage as exactly "230.0 V" which makes me think that 
this is the "set" value and not an actually measured value.

upsc command output gives the same result : « output.voltage: 230 » and no 
"input.voltage" field.


I was wondering if this shortcoming is due to the nut version I'm using now 
(2.4.1.-3ubuntu2), due to the Ellipse MAX 600 itself, or possibly due to using 
the serial connection rather than the USB...?

Also, I've tried to set a couple UPS parameters using "upsset.cgi", and I 
observed the following :

- I could change the default "battery.charge.low" parameter from "20" to "30".

- But when I tried to change "ups.delay.shutdown" and "ups.delay.start" 
parameters from their default "0" to "20" and "60" respectively, when I 
validated this in upsset.cgi, my UPS immediately killed power to the machine 
(?????) and, when power came back some seconds later, I could see that 
"ups.delay.shutdown" and "ups.delay.start" still both display "0".

So my question is "is this a bug or is this a feature" ? I won't play much 
with this unless I'm sure, at it seems to kill my server power... :-/

(Besides that, the Ellipse MAX 600 user manual is about non-existent... The 
thing is supposed to be "line-interactive" and there's no indication in the 
manual at all about any way to know when power boost or buck features activate 
or if they even really truly exist... Manual is "2 small pages in 294 
languages", too bad. There's more information on the box itself than in the 
manual :-/ My old UPS had more LEDs and a better manual...)

Kind regards.

Michel Bouissou <michel at bouissou.net> OpenPGP ID 0xEB04D09C

More information about the Nut-upsuser mailing list