[Nut-upsuser] Eaton / MGE Ellipse MAX 600 USBS and nut

Arjen de Korte nut+users at de-korte.org
Fri Jan 22 11:31:15 UTC 2010

Citeren Michel Bouissou <michel-nut op bouissou.net>:

> - This UPS supporting both serial (mge-shut) or USB (usbhid-ups)
> connections/drivers, is there a choice that is "better" than the other in
> Linux ? Do both drivers / connection methods give access to the exact same
> parameters / information on the UPS ?

Unless you're running the SVN trunk (= development) version, it's  
preferred to use the serial connection. The handling of some error  
messages that are returned by the MGE / Eaton Ellipse series in the  
'usbhid-ups' driver is suboptimal to put it mildly. This has been  
fixed in the development versions, but the latest stable release  
(2.4.1) will frequently reconnect to the UPS (which is noisy in the  

> - So far I've choosen "serial" for I assume the serial connection to be
> simpler and more reliable (?) (doesn't need any access to libusb,  
> doesn't need any filesystem mounted to communicate with UPS...)

Mostly true. If you have a serial port (natively, not via a USB to  
serial converter) is probably the most robust way to connect to any UPS.

> Well, once done, this works (see http://www.bouissou.net/ups ) but  
> I'm puzzled
> to see that my new UPS seems unable to display input voltage and that it
> always displays output voltage as exactly "230.0 V" which makes me think that
> this is the "set" value and not an actually measured value.

Sadly true. I have an Ellipse ASR 600 which also doesn't show a  
measured value (but rather a static one). Which surprised me too.

> upsc command output gives the same result : « output.voltage: 230 » and no
> "input.voltage" field.
> Annoying.

There is nothing we can do about this. The UPS doesn't return a  
measured value for the input voltage.

> I was wondering if this shortcoming is due to the nut version I'm using now
> (2.4.1.-3ubuntu2), due to the Ellipse MAX 600 itself, or possibly  
> due to using the serial connection rather than the USB...?

It's the UPS.

> Also, I've tried to set a couple UPS parameters using "upsset.cgi", and I
> observed the following :
> - I could change the default "battery.charge.low" parameter from  
> "20" to "30".


> - But when I tried to change "ups.delay.shutdown" and "ups.delay.start"
> parameters from their default "0" to "20" and "60" respectively, when I
> validated this in upsset.cgi, my UPS immediately killed power to the machine
> (?????) and, when power came back some seconds later, I could see that
> "ups.delay.shutdown" and "ups.delay.start" still both display "0".

I assume you're using the 'mge-shut' driver, right? In this driver,  
the parameters are actually timer (not delay) values which will start  
running immediately after writing them. This is confusing at best. If  
you only want to change the delay values, you must use the 'ondelay'  
and 'offdelay' parameters in 'ups.conf'.

In the 'newmge-shut' driver, the behavior is changed. In that case,  
the delay values will be stored in the driver and only be written (and  
timers started) to the UPS when a shutdown command is issued (which is  
more intuitive). But please note that this will only happen if you  
issue the shutdown command manually.

For automatic shutdowns, all drivers will be restarted in order to  
shutdown the UPS in the system halt script, which means that it will  
fallback to the build in defaults (or the 'ondelay' and 'offdelay'  
values from 'ups.conf'). So you can't change this from the upsset.cgi  

> So my question is "is this a bug or is this a feature" ? I won't play much
> with this unless I'm sure, at it seems to kill my server power... :-/

You should always do your setup (and testing) with a non-critical load  
connected. Testing with a live server is definitely not recommended,  
unless you've prepared your server to lose power unexpectedly.

Best regards, Arjen
Please keep list traffic on the list

More information about the Nut-upsuser mailing list