[Nut-upsuser] NUT upgrade to 2.6.0 in Gentoo with Liebert UPS

Arjen de Korte nut+users at de-korte.org
Tue Apr 5 06:53:48 UTC 2011

Citeren Francesco Talamona <francesco.talamona op know.eu>:

> I have a 64 bit Gentoo, with a Liebert UPS. The last NUT working version
> was sys-power/nut-2.4.1-r1 (I also tried sys-power/nut-2.4.3-r2 but
> downgraded, don't remember the reason).


> I don't know what else I can try, I simply don't understand what's going
> on. Donwgrade isn't a good option because nut-2.4.1-r1 is no more in the
> portage tree: it isn't impossible to install, but I prefer to make the
> new one work.

What on earth are you trying to do? I see you're trying out both  
serial (liebert) and USB (usbhid-ups) connected drivers, without  
reference of which one worked in an earlier version. I also see that  
you're attempting to run multiple driver instances in parallel (most  
likely, unintentionally) for the same UPS. This is never a good idea.  
Always make sure that when you're trying things out, the leftovers  
from earlier experiments are stopped.

Since the VID:PID combination of your UPS is not supported (not even  
in the development version), I suspect you've used the serial driver  
before. If that's the case it should still work, but most likely not  
if you connect the USB interface at the same time (in many cases,  
devices with both serial and USB share a lot of interface hardware  
internally). Chances are that your UPS might also work through USB,  
but I have never seen that before.

Best regards, Arjen
Please keep list traffic on the list (off-list replies will be rejected)

More information about the Nut-upsuser mailing list