[Nut-upsuser] NUT upgrade to 2.6.0 in Gentoo with Liebert UPS

Francesco Talamona francesco.talamona at know.eu
Wed Apr 6 19:25:51 UTC 2011

On Tuesday 05 April 2011, Arjen de Korte wrote:
> Citeren Francesco Talamona <francesco.talamona at know.eu>:
> > I have a 64 bit Gentoo, with a Liebert UPS. The last NUT working
> > version was sys-power/nut-2.4.1-r1 (I also tried
> > sys-power/nut-2.4.3-r2 but downgraded, don't remember the reason).
> [...]
> > I don't know what else I can try, I simply don't understand what's
> > going on. Donwgrade isn't a good option because nut-2.4.1-r1 is no
> > more in the portage tree: it isn't impossible to install, but I
> > prefer to make the new one work.
> What on earth are you trying to do? I see you're trying out both
> serial (liebert) and USB (usbhid-ups) connected drivers, without
> reference of which one worked in an earlier version. I also see that
> you're attempting to run multiple driver instances in parallel (most
> likely, unintentionally) for the same UPS. This is never a good idea.
> Always make sure that when you're trying things out, the leftovers
> from earlier experiments are stopped.
> Since the VID:PID combination of your UPS is not supported (not even
> in the development version), I suspect you've used the serial driver
> before. If that's the case it should still work, but most likely not
> if you connect the USB interface at the same time (in many cases,
> devices with both serial and USB share a lot of interface hardware
> internally). Chances are that your UPS might also work through USB,
> but I have never seen that before.
> Best regards, Arjen

I was simply trying to gather more information because the running 
setup, the one with liebert driver and nut user, wasn't able to run 
anymore with the upgrade. Sorry I didn't make it clear in the first 

I made too many tests and more than one driver get loaded in the same 

The UPS is attached only via USB, as always was, I don't have a serial 
connector for this device.

There's still something that beats me: I checked, and the first NUT 
installation was in 2008 the 2.0.5 version, with this very same UPS.
It could be with a different driver, but the device was always the same, 
always connected via USB.

Is it there a compatible driver, even if not fully-featured?

Many thanks for your reply
Linux Version 2.6.38-gentoo-r1, Compiled #1 SMP PREEMPT Fri Apr 1 
20:26:45 CEST 2011
Two 2.9GHz AMD Athlon 64 Processors, 4GB RAM, 11659 Bogomips Total

More information about the Nut-upsuser mailing list