[Nut-upsuser] beginner questions about AEC Star T4110

Gémes Géza geza at kzsdabas.hu
Thu Aug 11 13:37:09 UTC 2011

Hi Kjell,
> On Thursday 11 August 2011 10.55.39 Gémes Géza wrote:
>> Hi,
> Hi Géza. 
>> I've got an AEC Star T4110 connected with an RS232 port by a megatec cable.
>> On the list of supported devices
>> (http://www.networkupstools.org/stable-hcl.html) there is only one AEC
>> device, so I tried genericups with upstype=21. The problem is, that the
>> UPS (while being on-line) reports constantly being on battery.
>> # upsc aec ups.status
>> OB
> The only thing I could found on AEC T4(110), that it is a RS232 and have 
> 'dry contact' and 'SNMP' as option. And as it is a online ups and at least 
> 10KVA, I think it has some intelligent communication.
> So I don't think it is a working on the generic driver. If you don't have the
> 'dry contact' option installed.
>> My question is:
>> What is the recommended procedure to debug this (what parameters try to
>> change in what order)?
>> About the system:
>> Ubuntu 10.04 (kernel 2.6.32-33-generic)
>> NUT: 2.4.3-1ubuntu3.1
> I think it talks some megatec protocol. So if you can upgrade to a new NUT
> and test the 'blazer_ser' driver. Or the megatec driver in 2.4.
> Run it in debug mode. Locate where you have the ups driver. Then do
> /path/to/megatec -DD -a myups
> Where myups is the tag in the ups.conf
> [myups]
> 	driver=megatec
> 	port= /dev/ttyS0
> (end by CTRL+c)
> Cheers
> /Kjell
Thank you for your help.

Unfortunately it isn't working.

I have nut version 2.4.3-1ubuntu3.1 , so have tried the megatec driver:
    port= /dev/ttyS0

The output of # /lib/nut/megatec -DDDDDDDDDDDDDD -a aec
Network UPS Tools - Megatec protocol driver 1.6 (2.4.3)
   0.000000    send_to_all: SETINFO driver.parameter.port "/dev/ttyS0"
   0.000111    debug level is '14'
   0.001356    DTR=1, RTS=0
   0.001404    send_to_all: SETINFO device.type "ups"
   0.001424    send_to_all: SETINFO driver.version "2.4.3"
   0.001450    send_to_all: SETINFO driver.version.internal "1.6"
   0.001470    send_to_all: SETINFO driver.name "megatec"
   0.001485    Starting UPS detection process...
   0.001505    Asking for UPS information [I]...
   2.503689    I => FAILED [timeout]
   2.503712    Asking for UPS status [Q1]...
   5.105909    Q1 => FAILED [timeout]
   5.105930    Asking for UPS status [Q1]...
   7.708115    Q1 => FAILED [timeout]
   7.708134    Asking for UPS status [Q1]...
  10.310381    Q1 => FAILED [timeout]
  10.310404    Megatec protocol UPS not detected.
So it seams that it isn't "speaking" any megatec dialect :-(



More information about the Nut-upsuser mailing list